[4.21] Landscape not part of global distancefield

Since 4.21 I found that the landscape isn’t included in the global distance field, but it was in 4.20 and 4.18.
I’m unsure if its a bug or something on my end, I took screenshots from 4.21 and 4.20, both built with the blank template setup exactly the same with distance fields enabled & bAffectdistancefield lighting enabled on both terrains.

Before submitting a bug submission I wanted to check if others had this problem as well? I at first thought the distance to nearest surface material node was broken but on further inspection this is what I found.

Noticed this problem today as well, scenes I haven’t changed at all now are lacking distance field information from the landscapes. I think you should report it, hopefully they fix it quick as many of the effects in my current project utilize Landscape distance fields.

Just submitted a bug report, hopefully it can be resolved on Epic’s end

I do have this problem too. 4.21

Same with me… :0
4.20.3 works, 4.21.2 doesn’t. Reminds me why I never should work on the latest version…

Issue number or a link?

Sadly no issue number as epic has been unable to reproduce the problem so they haven’t added it. I was talking with them and we tried to find what could be causing it but it’s a problem they can’t find. I even tried sending project files to help but they are too big even with cutting down it’s size to send over email and google drive didn’t work for sending it either (even though the bug submission form recommends using it).

So sadly no update on the issue, which is a tad frustrating. I do suspect it might be hardware related but I’m unsure.

Same exact problem on my end, I tried to report the bug but they said they couldn’t reproduce the problem. My experience is identical to the OP and my screenshots were almost the same. It worked fine in 4.20.3, but no longer works in 4.21 when following the exact same steps. I have tested it on multiple PCs including a PC that has never had the Unreal engine editor installed on it, same problem. 4.20.3 works. 4.21 doesn’t.

Both PCs had Intel based i7 series processors and Nvidia based graphics hardware, a GTX 980ti and an RTX 2080ti, both have the same results.

Hopefully they can find some commonality to this, I don’t know if they will see this thread and see it affects more than just one or two users, but I guess if you have the problem, you can try and report it yourself to make it clear it’s a real issue?

I have the same problemo and also send this link with the screenshots and to fresh new example projects to them. Same Project, one is 4.20.3, one 4.21.2, one works, one doesn’t.

I have made a bug report and one of the epic guys send me a mail back that they were not able to reproduce. I answered his email back but got no response since then, wondering if I got something wrong, but there was no other thread I got provided with where I could send my response.

If anyone is interested, here is the link to my folder wither the projects.
Link: MEGA!

Problem persists in preview 4.22.0.
As Epic can’t reproduce the problem on their side, do you know if this problem could be hardware related? Maybe something about the graphics cards?

Thats been my sneaking suspension for a while now, my specs are:

i5 4960k
Nvidia GTX 970
16 GB Ram
Windows 7 64 bit

So unless the problem is also on Windows 10 it still a problem on even newer cards as well, as @AlphaJester92 pointed out

New update, I found that unless the distance field resolution is set high enough flat planes do not show up in either global or mesh distance field visualization, but when the resolution of the plane is increased (I set mine to 5 from 1) it not only could be visualized but actually pull other flat objects into the global distance field, namely the landscape.

So not sure exactly what the root cause is, but purely flat surfaces need higher distance field resolution, but since you can’t increase it on landscapes it won’t show in the global distance field and just ignore it. I plan to do some further tests, so here are some screenshots to show whats going on. I also tested on the 4.22 preview 1

Resolution set to 1 on a plane compared to 5
alt text

alt text

Sounds interesting. my specs are:
32 Gb RAM
Nvidia GeForce GTX 780Ti
Windows 10 Home 64bit

That thing about the plane sounds interesting. I tried to reproduce it on a university computer and failed, just like the epic devs. I believe that global distance fields used to have problems with older AMD graphics cards. Maybe it is something software or driver related, but my drivers (at least of my graphics card) are at the latest version…

I too have this problem with distance fields not working for landscapes. They work in 4.20.3 but not in 4.21.1 and also 4.22.0 Preview 2.
My specs: i5-3350P, 16GB RAM, Nvidia Geforce GTX 1060, Windows 7 64bit

The dev that I have been in touch with could still not reproduce it and therefore this thing was dropped. As this issue seams to be machine dependent this will not be resolved. Either we have luck and it starts working miraculously with a new edition or it will never be fixed.


I recently updated to Windows 10 from 7, and the problem is resolved now. So for me it’s resolved and seems to have been an issue with the older windows OS.

■■■■, but I am using windows 10 :0

It’s some kind of size optimisation. Set your landscape component size small enough so that it shows up in the visualization, which you can do to an existing landscape in the Manage tab.

This is the answer you’re all looking for. Hopefully this bug is fixed in a future release.

Landscape ‘Distance Field’ also broken for me in UE4.21.
Material in screenshot is based on the simple [Distance To Nearest Surface] shader example here:

See my answer above, you need to make your landscape component size smaller.