4.18.2 shaders compiling every map open

Hi, this seems to have started overnight, it wasnt there in 4.18.1 and the update seems to cause every map opening to have to compile 11,000 shaders. Thats far too many for effecient work, and as it seems to have appeared only after the update, i feel something strange may be happening,
Does anyone else have this, and are there any solutions?

HELP PLEASE! The problem just multiplied. Ive lost about 50 hours of work just now due to this compiler bug!!!
Please can you talk me through step by step restoring a backup from the saves directory. As i cant seem to open it with ‘open map.’ And when i copy the map file from backups to the main content file there are no assets in the rifht hand window?!

HELP. Very distresses.
the full story on the situtaion is : I wondered if there was a problem in file names after the 18.2 update, ie i had 5 versions of xxx build data, for old projects i had duplicated and then renamed and added to; all in the same directory for one map folder. I had none for the proejcts that kept compiling textures every time i opened the map, even though i clicked. I logically thought there was a file name error and that my map was building textures evenr time i open vut saving them under the wrong map name, due to sme unknown 18.2 bug. I thus what seemed logicaly deleted what looked like 5 suprious verisins of xxx map build data, only for ALL the maps to be deleted along with it.
1 i think this is unforgivable file control on epics part. Deleting one file to have it delete another as well is lunacy.
2 this only happened due to the 4.18.2 update i think as it was not doing this , compiling 11,000 items every map open, 48 hours ago.
3 i cant lose 50 hours of work and wouod REALLY appreciate how to resolve this!!!

Developer Jon X on the forums says to

“For those having this issue with the shaders compiling, try deleting the folder AppData\Local\UnrealEngine\Common\DerivedDataCache .”


It definitely help my project, I would have 35k materials compiling anytime any map would open.
I only tested opening my project twice after deleting the cache. once to build everything, and once to see if it would compile again after. It didn’t but it did take forever to actually open the first time.

Hey TalkingHead, Please try the suggestion above and let us know if it works.

The above process worked for me and my team! 4.18.2 with p4

Thanks this worked for me too !!

I deleted the folder but still it is compiling shaders… any other ideas? please help

Same here. I rebuild the engine from source and the problem still happen.

  • Open a map : Shaders compile
  • Wait compilation to finish (until there’s no ShaderCompilerWorker.exe in the process)
  • Save the map and exit
  • Reopen the same map : Shaders compile

I tryed deleting the temp folders in the engine folder and in the project folder. There’s more than 200Gb of free space on the SSD where both the engine and the project are installed.