[4.17.2] How to fix VS Debugger failing to start Editor?

I updated my project to 4.17.2, and Visual Studio to 2017.
Now when I try to debug in VS, it says it is unable to start the editor and that MSVSMON failed to start.
I also tried directly attaching to the Editor’s process but that also failed.

I get the following warning after a successful compile:

warning MSB4011: "F:\Work\VSC17\VSC\Common7\IDE\VC\VCTargets\Microsoft.Makefile.props" cannot be imported again. It was already imported at "C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\V140\Microsoft.cpp.props (31,3)". This is most likely a build authoring error. This subsequent import will be ignored. [F:\Documents\Unreal Projects\OrtCloud4\Intermediate\ProjectFiles\OrtCloud4.vcxproj]

The warning does not seem to impact the project or editor as my project still compiles with “1 success” in VS2017, and can be loaded into and compiled in the 4.17.2 version of the editor successfully.

In VS my project and the engine project both have the following appended to their displayed names(in the solution explorer):

(Visual Studio 2015)

I tried repairing the VS2017 install but there was no change.
How can I get Debugging to work again?

(also how do I get rid of that warning? could it be affecting the debugger?)

After a full reinstall it still didn’t work.
After re reading the “Setup Visual Studio” doc, I copied UE4.natvis into my VS folder.
Debugging now works.

I dunno if UE4.natvis is required for VS Debugging to work, but it this makes it seem like it is.
If it is required it may be prudent that someone update the “Setup Visual Studio” doc to reflect this, since the page only suggests that it “supports” and “allow easy inspection”. Which doesn’t necessarily suggest it is a requirement.

You should create a ticket for UE4 explaining this, it is a small chance that someone will just read this comment and do it.