[4.13] Plugin OnlineSubsystem Failed to Load on Engine Startup

Ever since updating to 4.13 I am unable to start unreal engine. I have been getting the following error when I try to start the engine:

Plugin ‘OnlineSubsystem’ failed to load because module ‘OnlineSubsystem’ does not appear to be compatible with the current version of the engine. The plugin may need to be recompiled.

I must note that I acquired Unreal Engine 4.13.1 directly from the launcher.

The main engine plugins that this deals with are the following:

  • OnlineSubsystem
  • OnlineSubsystemUtils
  • OnlineSubsystemNull

I figured out that these were the problem plugins through deleting each one sequentially and the next one showing up in the error message. I was able to start the engine once these were deleted. I was able to create a blueprint project and toy around a bit. Once I tried creating a code project it shows up with an error wanting these files. So is there a way to recompile or get these files to work in my engine.

I have tried the following to try to get it working:

  • Verified the files with these deleted
  • Modifying the .uplugin files to the current engine version
  • Delete Binaries and Intermediate files and trying to run it
  • Complete reinstall of the engine.

Any help would be great.

Here are the steps to replicate this on my end:

I click the Launch button for the engine

The error pops up

Then it goes back to the launcher

HI, the steam overlay system has changed. If you are using c++, then be sure to get rid of the steam stuff you may have put in previous.

Then right click on your project icon , open with notepad and add (in plugins) :

		"Name": "OnlineSubsystemSteam",
		"Enabled": true

Thank you for the response but this is not my problem. I cannot even create a project. I was able to create a non c++ project when removing the stated files. The problem is when I click the launch button within the launcher. It does not even bring up the project creation utility when launch is pressed.

I was able to fix my problem. What you need to do if this has been plaguing you is to fully uninstall the engine and the launcher. Remove all files off of your PC. Then reinstall the launcher and the engine while running the launcher as an administrator. This should allow the engine to start.

Swilliams provided the correct answer. Thank you.

Ya, Swilliams’ answer is correct.