4.11 Preview 1 No Stationary Skylight Bounce

Branch: Binary

Build: 4.11.0-2810555+++UE4+Release-4.1

It appears skylights set to stationary mode don’t apply a static secondary bounce anymore.
I rebuilt the lighting with a completely fresh install on the included third person example map with an additional cube added to show the effect.

The underside of the object is completely dark.

This is the scene rebuilt again - this time with the skylight set to static mode instead. Second bounce is back.

You will also notice that the skylight indirect lighting intensity slider has no effect, nor does adjusting the indirect lighting intensity slider in a post process volume when using a stationary skylight.

HI Calypso,

I’m not seeing the same issue on my end when comparing a new ThirdPerson Template project in 4.10 vs 4.11. I’m getting the same results.

You may want to include more information about your scene setup as well because it looks like you’ve disabled/removed some of the things from the basic map, like the sun or the skysphere. Even if I remove these assets I get the same results across both versions along with the Indirect Lighting Intensity slider working as intended.

Something to try:

  • In your screenshots there does appear to not be using the highest scalability settings so make sure that your Engine Scalability Settings is on EPIC.
  • Try in a blank unaltered project, like the ThirdPerson Temaplate

Let me know.


Hi Tim,

Sorry about that; you’re right about the additional map edits. I forgot to mention I removed the directional light as well to emphasis just the skylights affect without the directional lights bounce muddying the results. All engine scalability settings were set to EPIC on both examples.

Here is a new test - I apologize for the amount of steps but I wanted to make sure everything was completely constant. I performed the exact steps for both 4.10.1 and 4.11 preview.

  1. Created new blank template project
  2. Created new map - default layout
  3. Disabled affect world on included Light Source
  4. Disabled Colors Determined by Sun position on the Sky Sphere
  5. Added Shape_Cube mesh (StarterContent - Shapes - Shape_Cube)
  6. Moved cube mesh to coordinates 0,0,100
  7. Assigned M_Basic_Wall (StarterContent - Material - M_Basic_Wall) to both the Shape_Cube and level included Floor Mesh
  8. Created Camera at Location: -120, 210, 80 and Rotation: 0, 10, -60
  9. Added Lightmass importance volume and edited to fit around the level
  10. Added Post Process Volume - Checked unbound and set both Max and Min Brightness under Auto Exposure to 1 and Exposure Bias to -2.0.
  11. Added skylight to scene - No settings touched (set to stationary by default)
  12. Set lighting build quality to production and built lighting.

4.10 Result

4.11 Result

Back in 4.10, I then turned the Indirect Lighting Intensity slider to 0 under the SkyLight actor and rebuilt lighting. You can see now both 4.10 and 4.11 sync up perfectly.

Thanks, for the clear repro steps. I was able to narrow that down to just a few and have submitted the ticket with UE-24813. This should get an update in one of the preview builds between now and February when 4.11 final is released. Until the devs return from their holiday break I won’t have any further information for when this will be addressed.


Hi Tim, thank you for filing a ticket!

I just wanted to update you that as of preview 7 this bug is still in effect, however it seems like it was removed from the known issues list on the 4.11 preview forum post. Just wondering if there might have been a mix up, or possibly it was fixed internally and hasn’t made it to a public build yet.

Thanks again!

It’s still marked as “To Do”, however, it’s not listed as a fix version target of 4.11, so without that, it’s not going to show on the list of known issues for 4.11 that are being worked toward. I just checked in our internal build of 4.12 (CL-2894512) and this behavior is still the same. So, with that said I don’t have a timeframe for when this will be addressed.

Understood, I appreciate you checking in for me.