Download

4.11.0 Player character camera is on the floor

Hi all,

It’s been a while since I built a project for vr (4.8 i think) and now all my pawn characters look like they are lying on the floor (4.11.0)

Everything builds ok, so not sure what the problem is.

I’ve tried playing with the world scale and the capsule half height, but that just weirds things out.

Also tried the TP_BPFirstPersonRift template that was built with 4.10 and that gives the same results with the camera on the floor.

Any ideas?

Thanks!

Hi,

Any luck finding a solution? I’m having the same problem.

I dont know if this helps… but i had the same issue with the “Showdown VR” demo…

user RogueSheep said;

in the details panel of ‘Character2’, go to ‘Camera’ and set the ‘Base Eye Height’

the base eye height was set to 0… so changing that value, to like 110, did the trick

Im guessing it to do with the the fact that there refactoring a lot of the camera code for VR.

For me the camera is lower, not on the floor…and moving oculus towards/away from the sensor is moving the image left/right. Like some coordinate system is turned.

Oh, found a solution to my problem. Under character camera settings I unchecked Use pawn control rotation.
But still the behavior is different than in 4.10. Now where I look with my headset is not the forward direction of moving. Forward is where the character is initially going, only mouse can turn it. Will play with this some more.

I’m getting the same issue with the camera being too low to the ground as well as the movement control that Crayox described. I disabled pawn control rotation and checked Lock to HMD in the character’s camera settings. I wonder if anyone has successfully gotten VR mode to work correctly in 4.11?

Also, do you guys generally experience juddering with Oculus? I posted a thread how I eliminated it just by toggling “stereo on” in earlier versions, like 4.8 and before, and then after 4.10 everything is smooth when I run a VR simulation from the editor but when I build a test version and run it I get that judder again. Also I notice weird black frames in my right screen (or just on the right side of the view, not sure).

I do archviz, so I’m making that sort of scene. Can I post it somewhere so people can try it and see how it feels for them?

The Vive measures its HMD from the floor up, whereas the Rift measures from its “normal” position. This is likely related.

Crayox, I can help test it for you if you uploaded it somewhere. In general the VR sim runs smoothly, but I’ve never tried packaging a build to test it (at least not yet).

They have made this the new default, but you should be able to change it with control rotation or a setting in the camera manager.

This should force the player to move forward always where looking at.
499f3d3414c2e9be9e0e456fe561cdcff583206f.png

I can’t figure out how to raise the player’s height. I’ve tried eye height, camera position , capsule scale. Nothing worked. It’s like it gets overwritten by something at around 100-120 cm.

Edit: Nevermind finally fixed that with capsule half height.

Cool, will try the capsule half height.
Also, I’ve uploaded my scene if anyone wants to test it.

Half height won’t really work for me, my capsule gets too big and can’t go upstairs now. Not sure why camera height doesn’t help. They probably changed some default.

If you go into the player blueprint, select first person camera under components and then on the right (details)search hmd and UNcheck lock to HMD. Now when you raise and lower the camera on the BP viewport (don’t forget to compile), it will follow in your headset. This worked for the DK2 anyway…

Actually scratch that. Doing this creates a strange motion offset when turning your head. I’ll keep looking…

Half height parameter works for me…

Had to tweak my half height parameter a bit, but now it seems to work for me too. Changing it to a value too high made my character fall through the world.

I think you should just pull the capsule up again after you increase its height. For me, that made it too big to go to my second floor so I don’t like that option. Will have to find something else.

I had the same height problem, but I fixed it using the base rotation and base offset node in my character blueprint:

fd21145aa1d5d86104f5420006efdfc56c4dcadf.jpeg