4.10 Lighting Stuck at 0

Hello everyone. when I build my lighting it won’t build, I let it sit over night and the lighting is stuck at 0%. I have 33,000 objects in my scene, it’s an amazing scene and need to build the lighting and I have like 3 FPS. I need to finish my demo reel and look for my career, but can’t do that until this is fixed. I’ll post my system specs below. I have about 200 GB free left on my drive. I have plenty of space left to build. I put my settings to the lowest, the lightmass to 4. It is a bug or something? Because I’m pretty sure my computer can build it. I posted previous forums, but nothing builds for me.

OS X EL Capitan version 10.11.1
MacBook Pro (15-inch, Mid 2012)
Processor 2.6 GHz Intel Core i7
Memory 8GB 1600 MHz DDR8
Startup Disk Macintosh HD
Graphics NVIDIA GeForce GT 650M 1024 MB

-Brian V

Is the Output Log giving you any hints?

Where do I open the Output Log?


Oh there it is, thanks. I’ll let you know what it says.

Hey, I checked the logs when it’s building, heres what it says.

Based on your log output:
Does it get stuck at that last line?

If you have a lot of lightmass to calculate, which i assume from the output, you might want to reduce it.

Check this here: CPU Lightmass Global Illumination | Unreal Engine Documentation

See if you can reduce the lightmass calculation by using lower lightmaps, maybe that helps.
also make sure to use Lightmass Volumes for those areas where the player will be running around.

Also it is very wise to read the documentation in general, it helps a lot.

Hey, last question, can I use a map that Unreal let’s us have and build on it and make it my own map? Like the Landscape Mountain from the learn tab?

Yes, you can use all of the content from the Starter Pack and the Demo Projects for your own project.
Please read the EULA of each project for detailed informations.

Oh okay, thanks for letting me know.

Yea I tried lowering the size of the light volume and even tried deleting it. I lowered all the settings to the lowest. And it’s still stuck on 0%, maybe a glitch?

RyuuKishiSama I can’t build the lighting at all on any of my projects. This one and a project that I have 200 actors in it. I’ve allowed incoming connections in my firewall and allowed it. I’m not sure why it’s stuck at 0.

Well it’s hard to tell from here what’s wrong. You should not remove the light importance volume this will definitely rise build times.

Can you start a completely new Project and build the light in it? Does that work?
If so, try migrating your level from the old project to the new one. If it breaks you could start by removing stuff and see what causes the lightbuild to hang.

If not, try uninstalling and reinstalling the Unreal Engine.

That’s how i would go from here.

All right let me see if it will work. I’ll get back to you in a little bit. Thanks.

Yea it failed to build when I made a new project. I have a lightness volume on all of my scenes as well.

Heres what the log say’s. I can try to re download the engine. I tried that a while ago and it did the same thing. I’ll try it again.

So a completely new Project keeps hanging at 0%?
Well then something is definitely wrong with your installation.
You should reinstall it then.

Yea a completely new project. I’ll re-install it and let you know.

Hey Its able to build once I re-installed the engine for my smaller scenes. How long do you think the light build would take for a scene with 30,000 assets in it?

This depends on a lot of factors. How many lights are in your scene, material options, settings of importance volumes, refractions, reflections the available resources on your machine and so on. It can range from an hour to several hours.