3rd UV channel won't delete, even after proper reimport

All my meshes had 3 UV channels - I figured out it was because i was auto-generating lightmaps.

I turned that setting off under imprt settings and reimported the mesh - but the 3rd UV channel remains.

Is there anyway to get rid of the 3rd UV channel without deleting the mesh completely and importing anew? I have the meshes already placed within the scene…I’d like to avoid having to place them all over again.

Any chance you tried to reimport the meshes manually instead of using the “reimport” feature?
that way you can disable “auto generate uv’s”
Ive never had this problem myself, and ive been playing a lot with UV’s.

Thanks! That’s what I needed.

I had turned off ‘generate UVs’ under the mesh’s import settings, so assumed it would apply when reimporting. Guess not - but manually importing over the old asset worked like a charm.