3D Widget glowing in a dark map

Hi, i’m trying to make a MainMenu with 3D Widgets but UMG images look to glow when they are rendered on a 3D Widget.
I tried to change Lightmass settings but it’s still glowing.

Button on UMG:


Button on the 3D Widget:


How can i do to make the 3D Widget stop making light ? Thanks!

This is probably a byproduct of Eye Adaptation (automatic exposure) and bloom:

Eye adaptation is a feature in the engine that mimics the way your eyes adjust in real life depending on how bright or dark your surroundings are. When you suddenly go from a really dark building out into bright sunlight, the outside world looks REALLY bright for a little bit while your eyes adjust. Because most of your scene is black, UE4’s eye adaptation thinks you’re in a dark area, so it’s trying to brighten everything for you so you can see it better; hence the UI looks super bright. It would be like being in a super dark closet with just a crack of light from the outside world; the outside world would look really bright.

The glow itself is bloom. Bloom is a simulation of a real thing that happens where light going through lenses isn’t all perfectly redirected. Some light gets spilled over the “edges” and appears as a fuzzy mist around the main object. On medium-bright objects, the amount of light that’s spilling over is really small in comparison to the rest of the world, so you don’t notice it. But the brighter an object is, the brighter (and effectively larger) its bloom becomes. And because eye adaptation is making your UI super super bright, its bloom is also becoming so bright that you notice it.

I’d suggest two things:

  1. Firstly, if this totally black world isn’t actually where this UI will live, try viewing it in your actual environment. Chances are the automatic exposure won’t crank everything up so bright once you get a brighter surrounding scene, and the UI might look fine. However, if your real environment will actually be this dark, do the following:
  2. Adjust your automatic exposure settings so that it doesn’t adjust this much for dark scenes. I think those settings are in the camera. The link above describes it. If the camera isn’t adjusting so far for dark scenes, the UI won’t look white-hot and the bloom around it will probably all but disappear.

As you said, on the camera i changed the Auto Exposure settings as bellow:


And my 3D widget as no bloom anymore:


Thanks !

So for anyone coming across this (from a dozen other posts) and not wanting to mess up their entire PostProcess Settings:

the default 3D widget has an unlit material with an emmisive pass. Might work for most cases.
Copy and change to something with an optional emmisive value, and your widget will blend in nicely with the rest of your scene.


PS: sorry for bumping old thread

1 Like

sorry, NanopixelKim. Unable, your way is mistake.

If you change the base material to ‘Lit’ and then plug what was into the Emissive Color node to the Base Color node the widget will light normally like any other surface. Worked for me, hope it helps!


After reading through multiple of these threads without answer, found this video https://youtu.be/G8LAZTi1S-k which should actually help. Tested it and solved the problem for me.

Summary: Use the eyeadaptation node in your material