Download

100fps+ down to 18fps in the Rift???

Hey everyone,

We are working on a new test and I’m having a lot of issues with the Rift when playing my levels in Unreal 4.5. For this test, I have a very simple level:

https://dl.dropboxusercontent.com/u/3637484/Villusion/AtlantisTest_03.JPG

Here is the data of my frame rates when playing the scene:

  • New Editor Window: 58 fps
  • Standalone Game: 105 fps
  • Standalone Game with Rift enabled (typing command - “stereo on”): 37.5 fps
  • Standalone Game with Rift enabled (Alt+Enter): 18 fps

I’m running

  • Windows 8.1 64 bit
  • Intel Core i7 4700MQ @ 2.4 GHz
  • 32 GB Dual Channel DDR3 RAM
  • Intel HD Graphics 4600
  • NVidia GeForce GTX 770M 3 GB - 344.65 Driver
  • Oculus Runtime 0.4.3
  • VSync is off (turning it on and off create same results)

I am at a loss as to why the Rift is performing so poorly. Looking at my data and stats, does anyone have an idea what might be causing the extreme slowdown? It seems unlikely that Unreal Engine would perform so badly in the Rift with this little to process. I appreciate any help. Thank you!

Barry Zundel
Villusion Studios, LLC.

Make sure it’s using the right GPU, could by trying to use the Intel 4600 instead

I’ve made sure that in my NVidia settings, it’s using the NVidia GPU for the editor. However, I don’t know if that means that it’s using it in the rift. Is there a way that I can test to see which GPU is being used for the HDMI out?

I will say more. I have a ASUS ROG G750JH, very powerful gaming laptop, with support 3d Vision (NVidia GeForce GTX 780M 4GB).
Any game (any!) with full graphics settings - fly!!! (at 120 frames per second for 3D vision included!)
However Oculus even simple scenes very slow!

For me, this is very strange!

Also really want to understand it.

What screen percentage are you running at? Have you tried setting “hmd sp 100” for instance?

One guess would be potential difference in screen resolution?

I’m getting terrible performance ever since 4.3 and up. Still using 4.2.1. I’ve posted here and can’t get a decent answer as to why the move from 4.2.1 to 4.3-> cuts my frame rate in half. I’ve tried EVERYTHING, every optimization trick on these boards, tried all versions of runtime, and yes I can get it back up to near 60 fps but the quality suffers HORRIBLY. 4.2.1, I would switch to FXAA and the build would run at 60 fps and look great. No other tweaks needed. I’m hoping Unity 5 will be more VR friendly. Unity builds always seem to run great in VR.

I am currently using the “hmd sp 100” command by default in my level. Doesn’t seem to help at all or affect it.

tested with the following settings:
stat FPS
hmd sp 70
sg ResolutionQuality 40
sg ViewDistanceQuality0.3
sg AntiAliasingQuality 0
sg PostProcessQuality 0
sg ShadowQuality 0
sg TextureQuality 1
sg EffectsQuality 1

Graphics in doom 90s :slight_smile:

All the same problems remain.
No reliable work.

Really sucks. I’d like to get some of the new packs offered on the marketplace but 4.2.1 is the last version of the engine that gives me decent performance/quality in the rift, & most of the new content is only compatible with 4.4 or 4.5. VR doesn’t seem very high on Epic’s list of priorities :frowning:

I keep hearing people say this hover i worked since then and I have noticed performance get better especially with 4.6 and 4.3. I don’t have high end hardware I test with gtx 760s and I am able to make really good looking games and always hit 75. I will say its not perfect. I have lots of issues with the way it works and oculus in general but 4.5 and 4.6 work fine with VR.

Be sure to read up and watch the presentation video on the optimizations Epic did for their latest demo.

Well for me, and for a few other people that i know of, the performance problems started with the latest 0.4.3 Oculus runtime, not with a specific version of UE.
https://answers.unrealengine.com/questions/124299/451-capped-at-375-fps.html

Oculus already know about this and hopefully we will have a fix soon.

I’ve noticed a huge increase in FPS when not using stereo (Comparing 4.5.1 and 4.2.1 I’m getting almost 130fps in 4.5.1 vs 60 in 4.2.1) but in order to get my 60 FPS in 4.5.1 when in stereo mode, the ONLY setting that makes any difference is the hmd sp setting. If I spit two identical builds, one using 4.2.1 & one using 4.5.1, by setting the hmd sp to 180 in the 4.5.1 bld I can hit 60fps in the 4.5.1 version, & this is probably just an oversight on Epics part that the default is so high in 4.5.1. So now all the settings (as far as I can tell) are identical in both the 4.2.1 & 4.5.1 builds. I switched to FXAA in both but nothing else was touched. Now in both builds I’m getting 60fps, but the quality is considerably better in 4.2.1. I’ve maxed out all the sg. settings via the console and still the quality is nowhere near as good as the 4.2.1 build (and I take zero hit on frame rate by maxing out all the sg. settings btw).

-I’m using the DK1 with a GTX 760 under Windows 8
-I’ve tried this with 0.4.2 & 0.4.3 versions of Oculus runtime. Makes no difference.
-tried every combination of settings in the Oculus Config Utility, and monitor settings…I mean all.

The only thing I don’t have access to in 4.5.1 is the hmdwarp setting, (even when I disable the OVR_DIRECT_RENDER) and I’m thinking this is the setting I need access to to match the level of quality/frame rate I was getting with 4.2.1

Well I figured it out. I had the “Enable personalized rendering for this eye position” checked in the Oculus config utility. It was stretching the shader in an odd way making me lose resolution. I unchecked it, and set my hmd sp to around 180 and now im getting the same quality /frame rate that I was getting in 4.2.1 in 4.5.1…

…whew

I’ll have to try that out! I’ll let you know what I find. Keep your fingers crossed :slight_smile:

I’m also having abysmal performance…

I’m quite new at this, as I just started playing with Unreal engine (I do 3D visual FX by trade, not games)
So sorry if I’m off base here :slight_smile:

I tried changing “Enable personalized rendering for this eye position” and it simply didn’t change anything, performance wise.
Since it’s an option that every possible user would have on, it’s a good thing it didn’t change a thing… it would be awful to tell every user to change there settings.

In my case, I made a simple demo, that runs at over 220 fps but in VR.
If I put hmd sp to around 180 then the performance drops to 37.5 or less.

This seems really bad for me and makes me wonder if Unreal is the right choice for starting a new project…

Unreal is obviously the best looking engine and “Blueprints” seems perfect for someone like me… but if performance is a serious issue with this engine, there is kind of no point :frowning:

Is this something that is being looked at and will be fixed? Unreal seems like such an awesome engine and so well optimize for normal gaming, I wish I could get the same kind of performance with VR.

37.5 fps with vsync on just means that your app can’t reach 75 fps, so you lose a frame; it could be running at 74 fps with vsync off for instance (you can try “hmd vsync off” on the console to check). You could also try the previous 0.4.2 Oculus runtime to see if it helps, maybe you are having the same problem as me…

Also i don’t know at what resolution are you getting the 220 fps on a monitor, but i guess you do realise that by using “hmd sp 180” you are rendering internally at almost 4K… I think values between 130 and 140 are usually a better compromise between quality and performance.

On top of that VR is using a wide FOV and rendering once for each eye with a different perspective + distortion and chromatic aberration correction. I’m not saying that there’s no room for improvement (i surely hope so), but we also have to be realistic!

Oh, well that explains a lot, see, like I said… I’m a noob :slight_smile: I didn’t know that at 180 I was upping the quality that high, Yes I’ll try lower settings.

These test where done with 0.4.2, as 0.4.3, was just broken for me. Basically had a floor and a box in the middle of it and was getting 37.5.
Went and installed 0.4.2 and I can get complete scenes with a proper frame rate (if I don’t go nuts with the hmd sp values)

I’m wondering, are some of you using the beta of 4.6 ? So that you can use 0.4.3 properly?

Thanks

Just wanted to add that I’ve been working on a scene in 4.5.1 with the 0.4.2 runtime. I’ve been able to achieve 75fps in direct mode with the editor minimized. Last night I installed the 0.4.4 runtime files after hearing that most people were having much better performance and the vignette had been removed as well. But my results have been that good. Direct Mode is fairly worthless unless I turn down most of my post effects and AA, and Extended is better, but still no where as usable-able as things were in 0.4.2 and possibly the combination of 4.5.1.

Does anyone know if we have the option of running 4.6 with 4.2? I’m going to try to rebuild the scene in 4.6 as soon as I get back home. And then I’ll try that Oculus build of the engine on github before rolling back to the previous runtime and at worst the previous build of the engine. I was really needing the 3D UMG Widget feature. I’ll post my results later.