Yet another lighting error ( specific mesh)


I’ve encountered another problem and I cannot figure this one out. I have no clue what’s wrong with this mesh , I have tried separating it , creating manually lightmap , welding verts …nothing works, there is allways light passing through where it shouldn’t as well as main face not getting lit properly.


Could someone pls tell me what’s going on ?

Thank you.

In that screenshot I’ve tried separating the " shelfs " to another mesh.

Here is how it looks before separating: (there shouldn’t be any light passing through there)

or through here :


You have 3 UV channels on the mesh, are you sure that the lightmap coordinate index is set correctly?

Yup,channel 1 is manually made by me in 3ds max, channel 2 is generated by ue4.

This is the best I’ve managed so far, but still not good enough ( channel 1- imported from 3ds max - 512 res) :

How the light passes though there beats me …those polys have separated UVs.

Maybe upload the specific mesh here, also show unwrap + wireframe.

Hm, the lightmap resolution and the marging of the lightmap isles could have an influence on this. Have you checked that / can you post this UV grid ?
But other than that, wow this is so crazy beautiful and realistic . OMG



I ended up using it the way it was. Not very excited about the lighting there tho… tried uploading pic here but got error with 3 different resolutions/image sizes.

How large is the attenuation radius and source radius/length for each light?

A picture values 1000 words


I thought it might have been that your source radius was too large, but it’s set to 0. Try scaling down the attenuation radius so that it doesn’t intersect with the next shelf above. You miiight have to increase the intensity to make up for the smaller radius.

Cast shadows is OFF in that picture. That’s why it passes through the shelf.

What ? why ?

The light’s settings. “Cast shadows” setting is off. That is why the light shines through the shelves.

Cast shadows off:
Cast shadows on:

Well mate thanks but that is pretty obvious. You probably didn’t understand that those 2 vertical planes are not connected.

Light not passing through and casting shadow are 2 different things.

This statement is incorrect, both from an in-engine standpoint, and also a scientific one.

Light is passing through the shelf because it the light has been set to not cast shadows.

So could you please elaborate what exactly is the problem?

This is caused by your lights not casting shadows:

It doesn’t matter whether the UVs or polys are connected or not.

This is caused by a large shadow map bias in the mesh preview window:


Nothing you can do about that.

Also I assume you build lighting with production quality settings?

You are right, thought it through and the statement is incorrect.

The problem is/was that light was passing through. And it’s not only because the casting shadow setting was off. I’ve had problems with directional light passing through even before adding spot lights. Just like you see in the mesh preview window.

Yes production quality settings. I’ve moved on to the next project.

Thanks for helping.

Quality settings can certainly have an effect! Glad you’ve got it worked out :slight_smile:

Shadow in preview window is generated in real time unlike scene shadows in viewport after baking, leaking trough walls is caused by low resolution of shadowmaps. if directional light is leaking light trough scene its usually caused due to wrong uvs or interpolation of the samples during light bake process, in that case you might want to tweak values in world properties tab especially when dealing with thin geometry. Also turn on shadows and in case where indirect light is not that important you can try using dynamic lights