'XboxOne' Directory Refuses to Cook even with '-CookAll' and 'Asset Override'

It seems to be impossible to cook any folder with a reference to Xbox (and probably PS4) even when using the asset cooking overrides on PC.

I have a bunch of icons in a folder that are used for the UI when a controller is inserted. Works fine in PIE and assets are loaded as they should be, but they do NOT package into the Cooked Game regardless of what I do. I’ve tried using ‘Cook All Assets’ and ‘Asset Directories To Cook’ in the Packaging settings but neither works.

This issue seems to be reported on Answerhub a few time, so far without any official answer. It also occured pre-4.9 according to those posts.

Hey TheJamsh,

Could you please provide us your logs in a .txt format? Also include verbose reproduction steps to ensure this is being tested exactly as you had attempted the process.

Thank you!

Hey Samantha, weirdly enough somebody just posted about this on the forums. Turns out it’s an engine issue!

And here’s my answerhub issue from June :frowning: