wrong uv wrapping when outside 0-1 space


I have a problem on my uv wrapping on an imported object. The fact is that my uv are bigger and largely outside 0-1 limit (I have a second uv inside 0-1 for lightmap).

I was thinking that it would not be a problem but unfortunately this uv doesn’t display correctly (cf. screenshot and fbx file to show by yourself).

Do you know what happen ? Is that a bug or a parameter that I missed ? Thanks. Julien.

[link text][2]

Hello Julca,

I downloaded your “ground” file and imported it into UE4. I was able to see the same wavy lines that you have posted in your screenshot. I then viewed your UV’s inside of the details panel of your object. I see that you have the holes heavily triangulated from the corner of your object. I believe this is where the issue comes from.

Although this link deals primarily with light mapping it also touches on many of the principles and theories of UV unwrapping.

Have a look at the documentation and see what you can come up with.

Ok, after pooling more knowledge from our team I believe this solution will work for you. The engine calculates on a space from 0-1. Sometimes, when you build outside of this space, you have to tell the engine to calculate the full amount of UV space that you have assigned to an object.

What you will need to do is double click on the floor inside of UE4. This brings up the detail panel. From there, on the right side, click the “Build Settings” roll out tab. Under that tab is an option to “Use Full Precision UV’s.” Check this box on and hit apply changes at the bottom of this section. This tells the engine use the full UV space provided on this mesh.

I just tested this and it eliminates the UV issue.

Hello ,

Thank you for your response.

I know the unwrapping constraints for lightmap, but for standard uv (ie. not lightmap) that does not apply (for most of them).

And I can assure you that this wavy lines does not appear on any others softwares (Unity included : cf. screenshot).

So that’s a bug that I hope you can quickly fix because I have many objects like this to import for a project.

Thank you and sorry if I sound a bit rude.



You’re right ! That’s solved my issue !

Thanks you very much for your reactivity, you saved me a good headache :wink: !