Wrong lighting on mesh with hood

Hello i have a model with a hood and i’m having incorrect lighting and i would like to know what could be the reason.

The light is next to the character so his left side of the face shouldn’t be lit, as well as the top right part. What could create this issue? Wrong normals on the hood mesh?

Hey xlar8or,

Click on the hood mesh (if it is a separate actor), or the primitive mesh containing the hood, and check ‘Cast Shadow as Two-Sided’ found within the Details panel for the selected actor.

If you’re using a single plane you need to remember that only one face is rendered. There is no back for these. The ways around this are using the method above or using a two-sided material.

Thank you,

Andrew Hurley

Thank you for the reply. The hood is made out of 2 layers, the inner layer and the outer layer. I have two materials for the character mesh, Above waist and below waist and both are set to Two Sided. Regarding the option you mentioned i didn’t find that one, all i found was “Cast Shadow” and “Shadow Two Sided” for the SkeletalMeshActor i’m using, and turning both on doesn’t make a difference.

Hey Xlar8or,

There is also an option called ‘Dynamic Inset Shadow’ which will give you a higher effective shadow resolution and works well for character shadows.

I would also take a look at the normals of your mesh, just to make sure they are not flipped. Also be sure the material applied for the hood is also checked as ‘Two-Sided’ Another option to check would be the ‘Shadow Bias’ of the lights themselves.

Cheers,

Andrew Hurley

None of that seems to work. I’ve noticed that there is some kind of LOD lighting system in place, because i have a scene with only a point light as a light source and placing an object in the world i get different lighting if i’m near or far the object. Example:

Far:

Near:

Is there a way to tweak this?

The lighting issue you mention seems similar to this. Have a look and let us know if you’re able to compare to what’s in our Wiki Lighting Guide.

It didn’t fix completely on that mesh but with 10.0 in Bounds it’s not bad. I mentioned this issue because i thought it might be somehow related to the main problem, but i increased the bounds scale and it had no effect, so back to square one.

Hey xlar8or,

If you would like, and are okay with the idea, you can send me your .fbx file zipped into a folder. Simply upload the zipped folder to and external file sharing host, like DropBox, and provide me with the link in your response.

Thanks,

Andrew Hurley

Thank you for your support, i can send the hood on it’s own fbx.

Hey xlar8or,

I imported your hood and was able to get the lighting satisfactory tuning various settings in the light properties. You will also be able to modify the darkness through ambient occlusion. The link Tim provided is a great resource for finding answers to some of the more commonly known rendering issues.

As for the other issue, I cannot determine what the cause is because it seems you have a material on the mesh, which will effect how light responds to that object. You might not have that material applied to the specific LOD when it is occupying a majority of the screen space and using it’s highest LOD.

I am testing your issues and am not seeing the same results you are reporting. The shadows on your hood are going to come down to the specific light type you are using, the materials applied to the mesh, and the mobility of the object.

Thank you,

Andrew Hurley

I apologize for the late reply, been handling other problems. Thanks for looking into the model, can you please instead look at [this][1] blank project i did with just the hood and sphere representing the face? This represents exactly my problem, so it would help me a lot if we worked with the same base.

PS: This should be what you’ll get:

Hey xlar8or,

I am happy to download and test user’s projects, but only if the case is extreme and is considered a bug or a crash. Generally we would like to avoid solving issues for users, and instead guide users the correct location to look, in order to find the answer for themselves. This way you can learn first hand and retain the solution to your issue better.

With that in mind, I did download and test your issue again. As mentioned earlier, the issue you are seeing is going to come down to the settings within the light actor itself.

Shadow Bias - Hood Mesh

I managed to get the light bleed correct by setting the ‘Shadow Bias’ to 0.2 and moving the mesh up away from the floor. You are getting some lighting on your characters face because of some of the indirect light bounces from the floor.

Thank you,

Andrew Hurley

Seemed pretty bright and focused for indirect lighting from the floor, that’s why i never considered it as a cause. I did what you suggested and tweaked the values, but sometimes i still get the problem and i can’t lower the Shadow Bias below a certain value, because everything will start to look broken. I’ll try to tweak other values to see if it produces better results. Thanks for the help :slight_smile: