Wrong Focal Length for vertical Filmback when using Movie Render

I’ve already asked this in another part of the forum but maybe here would be better. I have a wrong focal length for vertical filmback when rendering with Movie Render. Here are screenshots

Viewport with settings


The result:Image00001.jpg

The High Resolution Screenshot:

I encountered the same exact thing when trying to do a high-res screenshot. The viewport preview shows correct camera focal length / FOV, and then rendering it results in closer zoom in my render. Plus, the horizontal angle changed a bit too, by about 15 degrees or something, as though the camera had swiveled to the right + down somewhat. I think there’s a second set of camera parameters that are involved in causing it, or two or three parameters in the cine camera actor’s details panel are connecting wrong and/or canceling the other setting(s) enough to result in the wrong zoom. I suggest modifying Aperture and/or F-Stop slightly to see if it corrects it, and potentially Focus Distance.

I think that’s a bug. I’ve got the right result by downsizing sensor sizes to short size by vertical, adjust the FOV than change sensor sizes back and it renders correctly, but will be incorrect in the viewport now.

Reducing sensor size decreases vertical FOV? and then changing actual FOV, followed by returning sensor size to initial, renders correctly? I don’t get it. Well, the viewport camera is not set to the same initial settings as the cine camera. But if the cine camera viewport view is incorrect then, it might have to do with resolution or a different setting. I think it is a bug too. What’s viewed in the preview window for cine camera needs to be the rendered result, at least as far as FOV and lighting.

The point here Unreal calculates FOV based on longer sensor side and the Movie Render does it based on the horizontal sensor side, that’s why my trick works. It’s definitely a bug.