Download

wrong collision?

Hi all…
Why this collision doesn’t work?
this object don’t block my path but i can get through
http://s17.postimg.org/3uhvlo1ln/Immagine.jpg

please can someone help me?

The purple box around the object is your collision. if you dont want to make boxes you can under static mesh settings - Collision complixity, you can enable use complex as simple. i wouldent recommend doing this for a hole scene tho as it can take up alot of cpu power

yes but i can walk over this mesh but i have this collision…why i can walkon the object?

Do you mean that you can walk through the mesh? -> check the collision settings of your character
Otherwise do this - click on the collision tab (at the top of the window) - remove collision - add box collision - try it again :slight_smile:

i done it but same error…yes fighter and sorry for my bad english

As I mentioned, check the collision settings of your character :slight_smile:

http://s22.postimg.org/lpp8qlxod/Immagine.jpg
I think that those are right…

can you upload your mesh?

https://mega.nz/#!hQZWVLxA!fBNZGp85HG6d4EFqnmtFx6zwv9iifB58PphJPOWrk1Q
here you can download, thanks for help man :smiley:

In the mesh editor open in the toolbar the collision window and select auto convex collision set the convex decomposition settings to maximum.

http://s18.postimg.org/dfnttpiat/Capture.jpg

I saw your mesh has no smoothing groups and the mesh is overlapping this will cause issues when texturing the mesh…

Greetingss,

Still not work,…
Maybe becayse my valors are differents? but this is my max
http://s24.postimg.org/p8ek8ygoh/Immagine.jpg

No you have to check the collision of your character!

i can collide with other object…only with this i can’t

I can with the default character walk in between the mesh but not inside the pillar over here it works fine.

But it has something to do with your character collision -> because the collision on the object looks correct. So it could might be that you have to make the capsule smaller or the object bigger :slight_smile:

yes you right :smiley: Make the object bigger…but…the original one was to big so i ve scaled it to the 0.0014 and if i increase he grown too much…
There is a way that can resolve?

I understand that i have to make it bigger…but i need only to make the object of that dimension…there is a way to solve this?

You could change the size of the collision capsule from your character -> then you dont have to change the size of the mesh :slight_smile:

but in this way don’t change all the others collision?