Download

World Aligned Normal Textures Not Working

Hello All,

So I have got an unwrapped 1.8million Tri-Count mesh with Nanite Enabled. (See Image Below)

Using a Material on it with World Aligned Textures, but the World Aligned Normals are not working. (See Image Below)

I am not sure if its a Bug with UE5 EA or if others are facing the same issue??

Disabling Nanite makes the World Aligned Normal textures work.

Regards,
Chetan Biswas

2 Likes

Same issue here. Looking for fix

2 Likes

Thanks for clearing this out.
I have had another individual on Twitter confirming the same problem.

Hopefully the UE5 Dev Team at EPIC will be notified about this issue.
Thank You.

2 Likes

Update: Now worked for me

  1. open material
  2. turn on “WorldSpace (B)” at WorldAlignedNormal node with Static Bool Param (set to True)
  3. turn off “Tangend Space Normal” at your material node (details page)