Download

working with cubemaps

I want to simply use my latitude/longitude HDR map as a a skybox in Unreal, so I plugged it to the skylight in the level but I don’t see it and I am getting weird reflections as you can see below, any ideas on how to fix it?

Disable the option Lower Hemisphere Is Solid Color on your Skylight.

Hi!

When you set a HDRI to the sky it won’t be visible!! It will produce the lighting! If you want to see it too, you’ll need to use a huge sphere (as skylight) with your HDRI image applied as texture…
…you also have cast shadow turned off… with MINIMAL indirect light intensity… …maybe you should check documentation and read/watch tutorials…

Reflections: are you using reflection captures and disable SSR?

It’s important to do a bit of reading of the docs, and look for videos to watch. However, it’s far more efficient to receive a set of instructions via the forum on how to basically set things up, complete with caveat(s) or several settings that can help it render well. Watching videos involves switching back and forth between tabs or windows, pausing / unpausing, rewinding / skipping, and remembering all the details that were just gone over. Typed instructions in the forum have the advantage of being able to get copied and pasted to Notepad, then referenced more easily.

Where’s the weird reflections? in the skylight sphere (left screenshot) on the other hemisphere? The scene in the right screenshot is the attached HDR texture, so I don’t see what’s wrong so far.

Note: I have told him to read the docs or look it up if i recall but he keeps posting very basic questions like this.

“When you set a HDRI to the sky it won’t be visible!! It will produce the lighting! If you want to see it too, you’ll need to use a huge sphere (as skylight) with your HDRI image applied as texture…”
Yes, you should use capture scene option, with a skybox not using mipmaps (Hook up reflection vector to your cubemap with a custom world normal of 0,0,0 and it will do the rest.

“…you also have cast shadow turned off… with MINIMAL indirect light intensity… …maybe you should check documentation and read/watch tutorials…”
The skylight is dynamic. Setting cast shadows would do nothing. And indirect light should always be 1/m2, or else reflections will be buggy and inconsistent in brightness, instead use exposure and multiply the skybox brightness or use some other hack…Maybe you should check documentation alongside him.

Guys I did read the documentation, but I just can’t believe that the only way to preview the skybox is the big sphere hack but I guess its the only way as you guys pointed!
The reflections are looking weird on the chrome sphere itself.

I was saying that it’s better (often) to get instructions and tips on how to do really specific things in the forums, especially after trying various things and it’s not working. What is the material graph of the chrome sphere? I’m having trouble with reflections in a 4.25 project, where lighting is jittery on surfaces that have reflectivity.

Read my post. “Disable the option Lower Hemisphere Is Solid Color on your Skylight.”

thanks for the feedback guys.
here is my simple chrome material and I disabled the Lower Hemisphere Is Solid Color option:


Only half the skylight is being reflected on the chrome sphere.

As far as i can see, they are fully reflected. However, since their lower part is black, only black is reflected. An usual spherical HDRI has color for the ground too, but both of your shown HDRI seem to be simple panoramas with a completely black lower half. So een if you deactivate “Lower half is solid color”, then you will still see black, because the actual HDRI is black in that region. For a test, you could take one of those HDRI and color their lower half red or green, and see, if that gets reflected or not.

Or grab one from here: HDRIs: Skies | HDRI Haven

That being said, in your chromeball, this half dark-half-bright reflection from the upper half of the hdri is interesting. This shouldn´t be there, it should be uniform, judging by the displayed hdri. Try to go into the texture and change it´s texture group from skybox to world, and see, if that does something helpful. Or just make an entirely new project, and test it there, if this reflection still create this weird reflection.

Also, to get a normal visible Sky, use the HDRI backdrop, that is there for this exact reason (if you don´t like the sphere solution). And check the option “Camera projection” to get rid of the distorted ground, or change its mesh to “Sphere_inversenormals” (it´s a sphere with inverted normals, check this thread: https://forums.unrealengine.com/deve…11#post1808511 ).
A skylight is not there to create a sky,** that is visible for the camera**. You need a geometry with your HDRI applied as material, to make your sky visible… and that is, what the HDRI backdrop is, or any mesh with a hdri cubemap applied.

The skylight isn’t where to place HDRi backdrop unless as a specified cubemap, which is still only utilized as a reference for lighting. It doesn’t map the backdrop image to the inside of the skysphere by being placed in the skylight. Your chrome sphere is simply a 3D mesh, a sphere, with a partially reflected image of the scene. It is not currently set to reflect the HDRi backdrop image which is plugged into the skylight (the night sky image I see in the skylight cubemap slot). How did you get that confused with the rendering of a complete backdrop? Even the HDRi backdrop actor comes with a dynamic skylight as its component, not as a skylight with HDRi image as component. The HDRi backdrop actor is the parent of the skylight, in no uncertain yet not easily explained terms. A skylight is for lighting, a backdrop actor is for mapping an image to the skysphere (or the background). And the above is correct that having an image with no ground in it is going to require painting or somehow adding a ground…in order to get the reflection of the ground in the chrome sphere (instead of an amorphous black area that corresponds to the reflection of the non-existent ground and any other space that is not occupied by a rendered image or color).

If it wasn’t done yet, put the skylight inside the HDRI backdrop actor, unless there is one in it already. In the doc it states to not have 2+ skylights because it could ruin things or not achieve the intended result. So ensure there is ONE skylight in the scene, and that it’s a component in the HDRI backdrop actor (click + drag it on the HDRI in the world outliner list). Set it to Movable if it’s not that. Place that night-time sky image in the HDRI for its background image which gets mapped to the inside of the HDRI backdrop mesh type (dome or box, also in the HDRI settings). Then try and test the same image in the ONE skylight that’s a component of the HDRI to see how it lights the scene. A darker image produces a darker scene, while a lighter / brighter image produces a lighter scene. The more of a color range there is in the skylight cubemap image, then the further extent it may have to light a scene. In other words, a cubemap is for lighting the scene from the color/light data in the image that is set as the cubemap.