Download

Workaround For Dark Material Light bouncing?

I’m doing a scene based on Witches Gulch in Wisconsin and I am having a hard time getting good GI. My cliff material is very dark is this the problem and if so is there a way around it?
Also, any tips in general about lighting would be appreciated.
Scene:

Hello

You can inside lightmass settings (material or world properties) set more than 1 to diffuse boost (you can put big values first to see what’s happen). Also, change the environment color to something less dark (black by default), maybe more blue/red (depending what’re you looking).

I recommend NOT changing the environment color. Because it is a constant Ambient Light. Instead, place a Static or Stationarry Skylight in the scene, it will capture the sky and tint the indirect light accordingly.

I also recommend changing the Diffuse Boost of the Mesh Material. 2-3 should be enough already.
Additionally, you can increase the “Indirect Lighting intensity” of your Lights.

Your current lighting itself will work fine to get GI. Only thing you need to do is increase the “Indirect Intensity” of your lights, so they will start bouncing more lights around.
Hope this helps
Cheers

Hi!

WOW so many different answers! :slight_smile:
+1! :wink:
So first of all you shouldn’t use too dark materials because as you see you’ll get unrealistic results!
You can almost always brighten up textures/materials inside Unreal!
You didn’t say anything about your lighting… is it static or dynamic…
With dynamic lights you won’t get GI so if you want realistic (and not faked) results you’ll need to use those…
I’d never change diffuse boost or indirect lighting intensity: they both tend to cause errors and your lighting will be off! /have seen a LOT of errors/problems because of those!!

What I would do is set your material brighter (try the unlit view mode and you should see a flat grey(ish) look!).
Then set your static/stationary lighting properly (with portals, Lightmass Importance Volume…). In your World settings under Lightmass I would go somewhere between 5-10 with both skylight and indirect lighting bounces the rest of the settings are up to you what quality you’re after…
You can adjust a lot with post processing! Brighten up the scene for one!
Well this is for a start… To be honest you shouldn’t have a problem to light up a scene like this in Unreal…

Also, I would check your exposure settings, that’s another thing people forget that will brighten their scenes.

You could also use the “replace lightmass” node or however it is called in your cliff material. The node changes basically the diffuse bounce GI from the original albedo to a color of your choice, for example light grey or even white.

Wow I have a lot to work with today!
OK
I tried already diffuse boost in material but maybe didn’t put a big enough number. Will try again today
I have not tried indirect intensity"
I already have a skylight in my scene which has a scenecubecapture rendered to texture to get more accurate GI color
light is stationary though I should probably change it to static since it’s just going to eventually be a prop scene and doesn’t need any runtime flexibility
I tried last night to put a solid white color on the walls and the river bed to see if that would improve my shadows and it did just a little. With the white material the shadows are not a problem but going back to the dark stone there is only a small improvement in the dark areas. I may increase the value of my wall texture somewhat though I’d like it to match the source as much as possible which is very dark
I have my number of indirect light bounces set to 4 according to documentation the time/return ratio decreases exponentially beyond 4 so I didn’t consider trying it but I will as a last resort
Auto exposure is turned off. Can I set a constant exposure value? I’ll have to look
I don’t have any experience with post-process but will investigate further
The replace lightmass node sounds like a really good way to go in the future w/o altering the appearance of a whole level.
Thank you everyone for the help!

So, since this is just going to be a showcase type scene, what I wound up doing this morning was cranked my skylight intensity up to 50. Combined with my local cubemap as the texture for the skylight this works really well until you build lighting and find that it starts over-contributing to the diffuse term in the fully lit pixels.
Thanks again everyone I learned a lot and am looking forward to experimenting with the suggestions!

So far brightening the texture, using the LightmassReplace node, and increasing diffuse contribution wash out the texture when it gets direct light.
The best answer for this situation is adjusting the exposure min/max in a post process volume. I set min to .8 while moving max has no effect on this particular scene up to the max setting of ten.
Thanks so much for the help :cheers: