Won't let me open C++ projects

I keep getting this error:

Running F:/UE_4.14/Engine/Binaries/DotNET/UnrealBuildTool.exe MyProject10 Development Win64 -project=“C:/Users/Gabriel/Documents/Unreal Projects/MyProject10/MyProject10.uproject” -editorrecompile -progress -noubtmakefiles -NoHotReloadFromIDE
@progress push 5%
Parsing headers for MyProject10Editor
Running UnrealHeaderTool “C:\Users\Gabriel\Documents\Unreal Projects\MyProject10\MyProject10.uproject” “C:\Users\Gabriel\Documents\Unreal Projects\MyProject10\Intermediate\Build\Win64\MyProject10Editor\Development\MyProject10Editor.uhtmanifest” -LogCmds=“loginit warning, logexit warning, logdatabase error” -Unattended -WarningsAsErrors -installed
Reflection code generated for MyProject10Editor in 5.0940096 seconds
@progress pop
Performing 7 actions (2 in parallel)
[2/7] Resource PCLaunch.rc
F:\UE_4.14\Engine\Source\Runtime\Launch\Resources\Windows\PCLaunch.rc(10) : fatal error RC1015: cannot open include file ‘windows.h’.
[3/7] Resource ModuleVersionResource.rc.inl
F:\UE_4.14\Engine\Source\Runtime\Core\Resources\Windows\ModuleVersionResource.rc.inl(3) : fatal error RC1015: cannot open include file ‘windows.h’.
f:\ue_4.14\engine\source\runtime\core\public\Windows/MinWindows.h(62): fatal error C1083: Cannot open include file: ‘windows.h’: No such file or directory
ERROR: UBT ERROR: Failed to produce item: C:\Users\Gabriel\Documents\Unreal Projects\MyProject10\Binaries\Win64\UE4Editor-MyProject10.dll
Total build time: 12.58 seconds

Hey there, make sure you have the required windows sdks. Is this your first time running?

Yes it’s my first time. I have the SDKs but they’re on my C drive while UE is on my F drive. Could this be why I’m getting the error?

Moved the sdks to the F drive but still didn’t work.

Make sure you’ve followed the Visual Studio installation steps here.

Thanks. Read it but it didn’t help

Dont know much more what to suggest except unstalling ue 4 and visual studio and install it again following all of the steps in a disk location with permissions.

Already tried installing and uninstalling.

See if doing any of this helps.

Nope none of it helped. Maybe adding some code to the project from visual studio would fix it?

Here’s the error I get in visual studio:

1>------ Build started: Project: UE4, Configuration: BuiltWithUnrealBuildTool Win32 ------
2>------ Build started: Project: MyProject3, Configuration: Development_Editor x64 ------
2>Compiling game modules for hot reload
2>Performing 9 actions (2 in parallel)
2>[2/9] Resource ModuleVersionResource.rc.inl
2>F:\UE_4.18\Engine\Source\Runtime\Core\Resources\Windows\ModuleVersionResource.rc.inl(3): fatal error RC1015: cannot open include file ‘windows.h’.
2>[3/9] Resource PCLaunch.rc
2>F:\UE_4.18\Engine\Source\Runtime\Launch\Resources\Windows\PCLaunch.rc(10): fatal error RC1015: cannot open include file ‘windows.h’.
2>C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\VC\Tools\MSVC\14.12.25827\INCLUDE\cstddef(7): fatal error C1083: Cannot open include file: ‘stddef.h’: No such file or directory
2>ERROR : UBT error : Failed to produce item: C:\Users\Gabriel\Documents\Unreal Projects\MyProject3\Binaries\Win64\UE4Editor-MyProject3-1108.dll
2>Total build time: 2.25 seconds (Local executor: 0.00 seconds)
2>C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\Common7\IDE\VC\VCTargets\Microsoft.MakeFile.Targets(44,5): error MSB3075: The command “F:\UE_4.18\Engine\Build\BatchFiles\Build.bat MyProject3Editor Win64 Development “C:\Users\Gabriel\Documents\Unreal Projects\MyProject3\MyProject3.uproject” -waitmutex” exited with code 5. Please verify that you have sufficient rights to run this command.
2>Done building project “MyProject3.vcxproj” – FAILED.
========== Build: 1 succeeded, 1 failed, 0 up-to-date, 0 skipped ==========

You could try it, but doubt it.

I tried to add some code around that include h thing from that link you sent me but it didn’t work hence the error above.