WMR Controller: Thumbsticks and Touchpad don't work

I’m on 4.25 and mapped my input to WMR controllers. The only thing that responds is the trigger, but I don’t get any signals from the thumbsticks nor the touchpad. Any ideas what I could do?

Same here. Tried changing inputs but no result. Is there any real support for WMR in Unreal Engine or should I just give up?

Just enable the ‘Microsoft Windows Mixed Reality’ plugin and restart.

Didn’t work for us. Also, we’re on the new OpenXR drivers for WMR. UE4’s native WMR support is pretty much abandoned, since the OpenXR plugin is here. Anyway, this is not the only problem we have with UE4 and WMR. :frowning:

I haven’t had wmr for sometime now but things were actually getting worse believe it or not right around the time when epic claimed to begin supporting wmr in editor. VR editing was broke day one and while that was bad enough I didn’t expect basic gaming to later become an issue?

This doesn’t sound good especially considering next gen wmr is on it’s way soon with HP Reverb G2.

Has you tested it through steamvr as i suspect that’s the only way it will work properly for the time being?

I had a similar problem with the Index and solved it by reading this thread;…gin/issues/142

I am putting together a project that auto-detects any controller and spawns the right mesh and animates the mesh using the inputs. That includes WMR and I had no problem getting the thumbstick and trackpad to work.

I am using 4.25 in which now the SteamVRInput plugin is fully integrated and on by default. Remember that the input axis need to be postfixed with _X and _Y for your regenerate and reload the action and controller bindings to work. So you’d have something like LeftThumbstick_X and LeftThumbstick_Y as input axis then regenerate and reload using SteamVRInput and it should work.