Download

Wierd shadows (not at mesh position)

Hey folks!

I got a wierd problem with my shadows.

You probably see the problem in this picture:

I hope you guys can help me! I used Unity3D previously and got the same problem there. So… i must be the problem :stuck_out_tongue:

Here are my propertys:
this is a point light. I have another one in this scene, but it’s far away, so it shouldn’t effect it. This light is movable and the doorframe is static. i changed the Attenuation Radius to 650 and the light color.

Unless you need the lights or mesh to be moving, change the light to static and build your lighting.

Hey and thanks for your answer!

I don’t need the light to be movable, so i changed it to static and clicked on “Build”. Now it brightens my whole room, eventhough my Attenuation Radius is 250. I don’t get it…

bump

Still have this problem. Has really nobody an explanation?

When you build static lighting it will try to render realistically, which will have light bounce off surfaces. So the preview shadows and lighting will show just the direct illumination, when you build your lighting it will bounce off the surfaces and the shadows won’t be black. There’s settings for indirect illumination in the Lightmass settings, I can’t remember what other settings there are for that with the light, you may be able to adjust the indirect illumination per light.

Thanks for your answer!!

Unfortunatly this doesn’t seem to answer my question. I made a new scene to ensure, that i have never made any mistakes. This is what i get:

Ok, so now i changed the lightmap resolution on this wall and get this result:

Much much better, but how do i soft this shadow now, because it’s a bit… jagged ^^

Sorry for all these noob questions. I just try to get into this Unreal thing :slight_smile:

The light has a radius for the source (not attenuation) increasing that will make the shadows softer.

Thanks for your answer! Indeed that solved the problem! :slight_smile: