Widgets Off Screen After Disabling HMD

I’m using Enable HMD to disable the VR Headset during the menus. However, doing that seems to cause the widgets to use the wrong resolution and go offscreen. The widgets are fine if I start the game with no VR headset connected in the first place. Is there something to force a screen size refresh after calling disabling HMD?

This only affects the game after building and running the standalone. In the editor preview, it works fine. It might be related to the game being full-screen on the built version.

That last sentence for me was the key to a workaround. It only affects fullscreen mode, so for now, I can start the game Windowed to avoid what looks like a bug. However, it would be good to have this fixed to not mess around with the game resolutions like this.

In case it helps anyone else, what I did was add this at Event BeginPlays in blueprints:
Execute Console Command: r.setres 1920x1080w

Same problem here.

Only in Oculus, in Vive works like a charm, but in oculus the resolution is a totally disaster…

Only if you start the app in non vr and enable it after with a button in the Widgets or something…