Download

Widgets causing me some grief! ZOrder / Focus / Game Mode?!

Hi all OK, so i thought i was getting pretty good at the UMG side of Unreal, since i’ve spent forever doing this UI… I am adding in extra functionality now so that when you click a button it merges camera to new camera and opens up a new widget, it also opens up a separate widget below it… the problem is that i can’t get them all to work at the same time! it’s something to do with the Z order I think we i’ve messed about with them and I can get one of them to work, and then the other but not at the same time. it’s weird because they don’t overlap and I have all the widgets set to “Self Hit test Invisible” here is what I have below…

This is my Generic “window” which will display info depending on custom event field, each one will then trigger opening of another widget, all i’m trying to do is click a button but still have the option to use the close button on top right. I also have a main menu i can click on in the top left of project which is un-effected so not sure why this is… I have set all the “add to viewports” for all my widgets to 0 this lets the simple button and my main UI to work but then not the exit button for the info window, i dont get it lol

Basic Button i’m trying to interact with

what you see in game so far…

Widget Graphic.jpg

Maybe I’m missing something but you say “I have all the widgets set to “Self Hit test Invisible””, yet in the graph you set them to visible. Try setting them to Self Hit Test Invisible. Or even removing them, seems redundant?

I have tried removing the “set visibility” or changing it to “Self Hit test Invisible”, however wthout the node the animation never gets seen. my animation of the widget is that it starts of hidden and then set to visible once it starts to fade open, I have tried “adding to viewport” but this doesn’t fix it either, i’m obviously doing something dumb, just can’t tell what it is!

Never mind, with fresh eyes I checked the animation for my button, I had set the visibility to my whole canvas and not my button so it was making everything else untouchable. SOLVED!