Widget 3D Transparency

The widget component has some of its materials parameters exposed. Select the widget component and change the Blend Mode to Transparent:

For even more control, make a copy of the material the widget is using and see what makes it tick.

I have added a Minimap for the First Person view which is a Widget3D attached to the camera with little offset, and I would like to add some transparency, similar to what is done in [Strike Vector][1].

I’ve been trying to add transparency through render opacity, changing the material opacity, changing the alpha of the Textures, but none of these work when I hit play, it renders at opacity 1.

Also, searching through the forums and answerhub I couldn’t find any answer to that.

Is it possible to add transparency for a Widget 3D or is it an Engine’s limitation? If so, any workaround on that situation?

A screenshot of my current result:

Thanks for the answer, I’ve followed your suggestion and also found that there’s a BlendMode parameter inside the Widget3D Component.

Setting the two of them to Transparent did the trick!


1 Like