Why when I build light its taking hours?

I know…this area is huge…and I have lightmass volume surrounding it…
But after 2 hourss it was only at 2 percent. I mean the area isnt like skyrim big…it’s not at all.
would anything else slow down the light building process?

Maybe it would help if you tell what you tried so far.

One thing is that you can play with the light mass settings in your level’s world settings. For example putting “Static lighting level scale” to about 4 reduces build time a lot.

1 Like

When you adjust parameters in the light mass like that what exactly is it affecting??? I’m new to lighting honestly.
I’ve never built an area this big or this detailed. I usually build prototypes. :confused:
All I’ve done Is try to build on production and high settings. I’ve honestly never played with the settings in my light mass volume…
Are there certain settings inside I need to learn more about to affect my lighting process? I’m not casting shadows with ANY of lights because in the past I’ve never been able to get it to run. It seems adding shadows is a very large cut into my resources…and when I build light afterwards when casting shadows my fps is so bad nothing is playable. Even on a packaged build.

So please. Any information on what I need to learn would be wonderful. I’ll attempt to set the static lighting to 4 as told. I’d just like to understand what exactly it’s doing.

Thank you for responding.

I think its reducing the amount of samples taken to build your lightmaps during the build process.

Also if you are not sure if something could harm your project, better make a copy first. Thank you.

I’ve gotten it to build with the light quality at preview and the static light level scale at 4. Afterwards tho, it gets stuck after its complete while importing the static lighting. Then it crashes after a couple hours. .
Any idea what else can help build lighting on huge levels?

If your static lighting is taking that long and crashing that much then it’s possible you are having memory problems. If the level really is huge and isn’t broken into several streaming areas then you might run out of memory. You could try switching to dynamic lighting which will be more expensive on the gpu but will take a lot less time to bake and won’t createvas many lightmaps. Or you could leave the lighting as static and break your huge level into smaller streaming levels.

Swarm? What and where is this exactly?

Open Swarm and set Standalone Mode to True

When you build lights in the system tray you have a yellow icon, open it then go in settings and set tu TRUE standalone mode. Leve a message if it works. At least this what I did (before for me take forever to build)

I’m really trying here but honestly have no idea what you are talking about. lol im sorry. Could you explain what you mean by system tray? Could;d you post a pic by chance?

How about previous version of this level. I guess that its not the first time you tried to build the lighing for it.

So if you saved previous version of your level see after which changes it suddenly takes so long to build.

I had turned the shadows off for a while so I didn’t build lighting for MAN hours of creation. Someone jeeps talking to me about swarm. I honestly have no idea what that is. It’s getting stuck EVERY time I build. Even if I make the light mass a little smaller. Preview quality. I think it’s the actor Count. 4300. Someone said that was possibly too much but I honestly do know. Maybe I should export some models together and bring them back to drop the count? I still feel like it’s be taking up most of the same resources…anyone have any other ideas?

Ok… I am sorry for my English…tomorrow I will make a video tutorial about that…and I’ll post you the you tube address. so stay tuned and if you want to learn unreal I have many many secrets to share. Just watch my tutorials on youtube

Ok please do. And yes I’ll definitely check out your channel

in meanwhile look in system tray (where you have …windows clock, volume icon,… ) and you will see a yellow-black icon (only appear when you build lights)

I’m not speaking the same language or something I don’t know hat you even mean by system tray. I us UE4 and Blueprints.

Ok let’s see if it works for you. For me was a really help. Go to - YouTube

I’m not sure where you got swarm but I don’t have it…

Always when build lights, the Swarm Agent open automatically. If you don’t havet then you have a problem with the engine itself

I’m double checking. I’ll get back. I think I see now.