Why UTwitterIntegrationBase can not work properly?


I saw this comment by epic staff.

I tried to develop twitter login and I found GetTwitterIntegrationSingleton class.
I tried to use GetTwitterIntegrationSingleton but I can’t compile my project after use this class
c++ code ex)


I think this class is uncompleted. When can you update this class?..

No body will be able to help you if you just say “I can’t compile my project after use this class”, you are not end-user anymore in game development. Paste exact error you getting, compile in VS and look on Output tab insted or Error list which is buggy with UBT and can miss impotent info.

Also try using UPlatformInterfaceBase insted of UTwitterIntegrationBase

Hi. I’m same problem.

I use this code.

// @todo document
static class UTwitterIntegrationBase* GetTwitterIntegrationSingleton();



error LNK2019: unresolved external symbol “public: static class UTwitterIntegrationBase * __cdecl UPlatformInterfaceBase::GetTwitterIntegrationSingleton(void)”

How to get TwitterIntegrationSingleton?