Download

why the lights are not the same on my editor and the test window ?

hi, i’m trying to fix some problems that i have with my level’s lights, i have a few points lights that are overlaping and i’m trying to remove that issue from my level.

the main problem is that in my editor window i see my level more iluminated than when i tested the level in the editor.

in the first time when this was happend, i have put some extra point lights, but when i did this, i came with the problem of the overlaping lights, now i’m trying to fix this problem, but don’t know how to do it, here i have two pictures, the first one is how the lights lookd in the editor and the second one is how it looks when i test the game.

in game the scene looks too much dark, the front door is not visible.

8df720f92b02dd4a5c1d30fb45c2670ccd9802b7.jpeg

25fe289b08dba1755e9c97db062d848272d24a15.jpeg

i checked on the forum, but i didn’t found any answer, somebody can help me to figure out this issue?

thanks in advance for all the help.

Did you build your lighting?

yes darthviper107, i have build the lights so many times, tried already with lightmass volume importance and without it and also tried with a post-processing volume but is still the same.

any ideas ?

With out seeing how you are doing it the first image is what I would expect to see if you made any kind of value change that would require recompiling of the light maps and since it is such a confined space then that would be everything.

The second image is what I would expect to see after the light maps are compiled based on whatever environmental color has been selected.

If you want A to match B then my first suspect would be your environment color is to dark.

hi FrankieV, don’t know waht you mean with “if you made any kind of value change tha would require recompiling”, i’m using the first person template game and i don’t have modified any class in the code yet, i’m assuming that if i don’t make any modifications to the code the engine is fine and don’t need any recompilation. (i’m right ?).

my last question where i can change the environment color ?

thanks for the replies …

i found where to change the environment color in the lightmass properties, i switched the black one from there to white, i have re-builded the lights, but still the same.

If you change a light value, make it brighter or darker, then the light map on a given object will reset, more or less turning all white, as the lighting and shadow information is no longer valid. A light map is nothing more than a rendered image that is blended with you scene material.

In the update I believe that a watermark was added that if the lightmap solution is no longer valid then it stamps “preview” all over the place. Life would be easier if you could make the map available as solving lighting problems is one of the hard ones.

Anyways…

Of the two, and as to the number of lights assuming a stock setting, it’s the second image I would have expected as the result and not the first so I bet it’s a editor setting.

Run your alt key (alt 1 alt 2 alt 3).

Bet it’s one of those or some other editor setting used to modify the view port. Looking into dark places all day gives me a headache.

i fixed the problem using this video

after saw that video i came back to my old point light configuration and change the point light with the red X to a static point light and the red X was removed and my scene is not darkest anymore.

thanks for the replies.