Download

Why oh why - UV Lightmap with movable lights issues.

Hello everybody!
First of all, I must clarify that I am very new to Unreal world, as I have been fighting with it for the last 2 weeks.

My goal is to recreate an airline chair that I created with Blender. Unfortunatelly, I am having a real bad time with this because of the UV lightmap.

Ok, my unwrapping skills are very limited, so I got to unwrap my model in Blender nice enough to make it look nice enough. But, when it comes to import it into Unreal Engine, you need a 2nd UV channel with lightmap, with isolated islands and so. I have already learnt that.

I am trying to get rid of the problem by auto-generating 2nd UV channel inside Unreal, and apparently it does a very nice job… but as you may know, it is not perfect. And that’s why I am getting a 12.9% of overlapping, which is ruining my render.
9d27477903bdf22ec9b47d2e36dee7013925cb80.jpeg

I have tried changing the lightmap resolution, I tried with both static and movable lights… and nothing, I still get the overlapping.
At this moment I am importing the FBX with combined meshes, so I could try to import it with non-combined meshes, although that would be a mess because they are more than 50 different objects in 1 chair, and I need 50 chairs in my scene.
I also can try to decimate the original mesh in Blender, and try to simplify it and to create a more friendly UV map with better seams. But that is my weak point, I can die trying that.
I really wonder, how is it possible that, in mesh editor inside Unreal, I can see my chair just perfectly, and when I put it into the world and build it, it just goes that wrong?
2.jpg

Is there any way to get it to look as it does in the mesh inspector? If I just could get that result, it would be perfect for me!! textures, lighting and shadows, are perfect there.

Thank you all very much for your help, and sorry for these newbie doubts :frowning:

The static mesh editor is just a simple scene with an HDR image, there’s an Advanced_Lighting template that’s included under maps when you use the starter content with a new project that’s already setup like that.

Creating a good lightmap requires being pretty good at unwrapping meshes, and creating models that will light map well. It definitely requires some practice and getting used to, I would avoid using the automatically generated ones except for extremely simple meshes, tiny unimportant assets, or background assets.

Thank you ZacD!

Yes, I have read people saying what you are saying: I should try to avoid the automatically generated lightmaps. But in this case I think it will not be possible, as time is critical and I need a working level to be able to go on with it. Next time, no doubts, I will model it thinking on the final unwrapping, but this time I have to find a way to just go on… :confused:

Abour the mesh editor, the quality that I see there is way better of the quality in my world… I don’t know if it’s just because of the HDR image… All textures and meshes are displayed beautifully there. I don’t want to built any lights, I don’t need moveable lighting, I just need to press “Play” and be able to see my model as it seems in the mesh editor… Dunno if it’s possible though :S

You can’t build lighting without Lightmaps(and have it look nice), but you can skip light building and use Moveable lights.

Switch to the Advanced Lighting scene since they already have it set up with the HDRI and Directional Light. Change the Directional Light and Skylight to Moveable. You’ll lose some features, like baked occlusion and GI. Make sure you have multiple Reflection Actors in the scene. They should capture the HDRI, but not the Moveable lighting.

Does this help?

@leleuxart @antoniobradiano thank you very much guys!
I’m going to try with those skylight and directional light making them moveable and see what happens. Also I am triangulating and decimating my mesh in order to try to get an easier to unwrap map.
I will let you know the result!

Triangulating and decimating usually makes unwrapping harder.

I am working with 4 million vertices, it is that or suicide, those are my options :smiley:

Your best bet is making the low poly from scratch.

I know… you are right. In this case, time is critical, that’s why I am having these problems :frowning: Next time, I sure will start from low-poly

In the mesh inspector, the lighting is dynamic+HDRi so if you really want the same, use moveable lights+HDRi in your scene…at your own risk of performance issues i’d say :slight_smile:
Well if it 's for one first class seat it will be ok i think, for all the cabin seats, no.

Yes, if all your lights are movable, it doesn’t matter what your light map UVs are – you can re-use the regular texture coordinates. The cooker may still complain, but there will be no visible artifacts.

However, if you claim that you use auto-generated light map coordinates, yet the engine sees 12% overlap – that’s either a bug, or you’re using it wrong. After you auto-geenrate the light map coordinates, do you select that coordinate set as the light map coordinate set in the static mesh properties? If you do, and still see the overlap, you should probably file a bug about it!

Hi!!
Yepp jwatte, that’s what sounded more strange to me. I use auto-generated UV, I select the UV1 for lightmap, I check that UV0 is my original unwrapping and that UV1 is the nice one, and still I get overlapping… :confused:
If you see my autogenerated UV in the picture of my thread, it seems to me that, in fact, there is overlapping, but I don’t know why. Check the red boxes, don’t you think that could be overlapping?
1.jpg

I am confused about that. But yeah, I will go with moveable lights+HDRi this time. That, and a little bit of ambient occlusion, should get the job done (althought I can’t see much of indirect lighting shadows, everything looks like… quite flat to me, but I guess it’s ok for this time…

Thanks!