Why my ship does not collide?

Hello

I’m making a small game, in i there is a ship, i needs to have a collision to detect death

Both the capsule and the ship needs to have a collision, because the capsule is making the minimum height and the ship the collision to trigger the death
The mesh does have a collision shape, but it collides with NOTHING
how to enable that and trigger an event when an actor is hit ?

Atm characters only support collision from capsules → so you will have to use the capsule as the collider (set it to block all). :slight_smile: So set the collision mode from the capsule to “block all” and the one from the ship to “overlap all” (now when somethings overlaps with the ship, it should fire an event)

Yeah but i need it to collide, is there any way to force that, it is vital for me

i have a project with ships that are almost the same (bit spooky looking at the picture you posted) i don’t know what an Atm character is but i don’t use a collision capsule, if you open the static mesh asset Ship_exptest you should be able to easily create collision capsules ranging from a simple box to a reasonably tight mesh hugging shape, any problems let me know and ill have a look at my project.

i think he meant “At the moment”

Already set a collision mesh, didnt worked for me

Let me rephrase that, it is vital for me to have a proper collision for many reason: Realism and gameplay:
Imagine that, in my game you control the ship, you need to go between 2 Obstacles very close, you could pass without even moving because the collision capsule is too small to hit them, first thing the player is going to say “■■■■, that’s a ■■■■■■ coded game !” and leave.
You know, for me it is really needed, with all the firepower of the unreal engine, there should be a workaround, i’m pretty sure there is one :stuck_out_tongue:

Let me rephrase that, it is vital for me to have a proper collision for many reason: Realism and gameplay: Imagine that, in my game you control the ship, you need to go between 2 Obstacles very close, you could pass without even moving because the collision capsule is too small to hit them, first thing the player is going to say “■■■■, that’s a ■■■■■■ coded game !” and leave. You know, for me it is really needed, with all the firepower of the unreal engine, there should be a workaround, i’m pretty sure there is one :stuck_out_tongue:

You could create a collision channel for just ships and have it block whatever you want (probably everything depending how your ocean is setup) in project settings → physics. Most collission stuff can be handled through the deatils of a mesh → physics → collission and setting up collission primitives for static meshes and a PhaT for skeletal. Make sure you have collisions setup for your mesh aka make sure when it hits omething it doesnt just no-clip/ghost through.