Download

Why my shadow is low res even if I'm set 512-1024 ?

build ->lightinfo->lightmap resolution (as it shown in first top image , won’t work)
no effect even if I set 100000 . (I thought its a kind of a global value for all static meshes)

I also see overrides (second image) , when I’m adjusting by override it works fine .
what is wrong with global parameter upthere ?

I’m using bp_sky_sphere , is that best sky model in UE ?
I mean it casts GI from sky and direct light works without problems in big scenes (light bake)
any experience sharing would be great .

I inserted tirect light source as an actor into sky sphere , but when I’m rotating (tilt) that direct light
it seems sky is not reacting , it should go from night to day and vice versa .
what is wrong with that ?

The Sky Sphere isn’t a light! it’s just a Sphere with an unlit Material. It does not cast lights or anything.
The Sky Light uses objects in the distance to create a cubemap and lights the map according to this cubemap.
The Sky Sphere is mostly captured in the Sky Light.

As for the Directional Light and Sky Sphere:
The Sky Sphere has a boolean “refresh Materials”. Click on it and it should readjust the sun.

thanks for answer . but still can’t understand why global lightmap resolution isn’t working
but override resolution works fine .

it casts light if actor is directional light , but without sun actor its just a texture , ok .
“The Sky Sphere is mostly captured in the Sky Light.” this line is completely alien for me .
and still can’t understand can I receive light bleeding with blue color on objects if I’m using BP_Sky_sphere
in other words does it contributrtes to GI ?

I now understand what you exactly mean. No. The Sky Sphere alone does not do anything.

If you want to have blue tint (due to the sky) in your level (be it GI or not), you have to use a Sky Light.

The Sky SPHERE is just cosmetic, because it changes it’s colours according to a directional light.

A Sky LIGHT captures everything beyond SkyLightThreshold (which is most of the case the Sky SPHERE) and applies the colours of it as a global light.

ok , now I know that bp_sky_sphere is just a cosmetic that will not affect anything in any situation
its just a HDRI without light casting from it , it fits my expectations in that case

but what about global lightmap resolution adjust , why that is not affecting lightmap quality ?
again only way to change lightmap resolution is to check Override checkbox and type value there
second image with red rectingle on feature


and by the way why I can’t bake 4096 resolution map
it takes time but after finish , I see no shadows all is clear
?

The Adjustment of Lightmap Resolution only works between Min/Max.

If you have Min = 256 and Max = 1024,
The adjustment will only affect the static Meshes with a Lightmap Resolution between 256x256 and 1024x1024. everything else stays unaffected :slight_smile:

believe me , I turned off overrides
only left global between 32-256
no affect , still ****… quality
I increased 512-2048 and guess what ? same results , no changes at all
geometry is static and light in directional static … any ideas why that dude never afects shadow quality ??
(it doesn’t even affects the time of calculation)

one more thing:
is lightmass default gi solution in UE ?

You probably don’t know what the Adjustment does, do you?
The adjustment simply applies the Ratio to the Lightmaps that are within the range of Min/Max.
You have to adjust your ratio to see any results.
Min= 64
Max = 256
Ratio = 200


Static Mesh Lightmap Resolution (original) : 32
Static Mesh Lightmap Resolution (adjusted) : 32

Static Mesh Lightmap Resolution (Original) : 128
Static Mesh Lightmap Resolution (Adjusted) : 256

Lightmass is prebaked GI. So it’s not dynamic. If you want dynamic GI with built-in features, you need to use Light Propagation Volumes.
You may also build the VXGI branch. But it’s not very performant.

Your floor looks like a BSP object (block.)

If it is, then SMALLER values cause better shadows. So set the BSP maximum resolution to somewhere between 8 and 16 for a better shadow on the ground.
Really high-quality shadows will use 2/3/4 for BSPs. That also uses lots of video RAM …

a4ebb4107b8f9b628202a258c30d0fd99030b3cc.jpeg

I really don’t understand anything because
look at that image , firt top is low ratio
second bottom is with high setytings …
why is there no difference in shadow quality after baking?

its not BSP