Why my pointlight can't cast shadow?

My point light has tun on the "cast shadow"option ,and my models has turn on "cast shadow " too ,but I still can’t see shadow on my screen , is there any option I havn’t turn on or


thankyou , It seems to work ,but when I move the pointlight,those shadow has gone,I am following a step by step training course, when the auther move his pointlight , the shaow moves , do you know why?

would you please tell me why?

You need to rebuild your shadows iirc.(Build bar on the top)

my assumption is that he has dynamic lighting being rebuilt. Truth be told it’s a very expensive process and might not be the best approach. There should be an option to preview shadowing.

There should be an option to turn on Shadow Previewing.

I wish I don’t boring you , one more question , where is the "Shadow Previewing"option?

I was following a "step by step "course,and the auther choose a sationary pointlight,and the shadow is realtime, I have turn on the "cast dynamic shadow"for the pointlight, but I can see noshadow with my models

Sounds like your pointlight is set to Static or Stationary. Which means anytime you change it, you will need to rebuild lighting to see the effects, if you want to be able to move the light dynamically, you will need to change the Light to moveable. You should be able to see this option in the settings for the light under the transform options.

Are the objects in particular that are not casting shadows Moveable or Static? Can be seen in the Details section. A Stationary light will cast a dynamic shadow on moveable objects and static shadows on static objects. So if the objects are static, you will need to rebuild the lighting to see the shadows. Otherwise the objects will need to be set to Moveable to have them cast Dynamic shadows.

EDIT: Apparently even with stationary set, the lighting needs to be rebuilt to see the shadows cast by moveable objects. After which the object can be moved and the shadow will move with it. But moving the light will result in you having to rebuild the lighting. So with Stationary. Objects can be moved, lights can not be after lighting rebuilds.

It needs to be Movable, which can be found in the light’s details panel. It also needs to have Casts Shadows and Affects World enabled.


I apologize for using the wrong words, as they weren’t the options that you would need to use to make dynamic shadows (They are options underneath the shadow quality settings in the build dropdown menu) and someone else in the comments elaborated quite well on the issue. Hopefully that image helps.

I have change everyting into moveable,but it sill cast noshadow

Try to increase the lightmap resolution on the ground plane

You may have to rebuild your lighting for the scene before changes take effect.

You shouldn’t mark posts as answered if your problem hasn’t been solved!

For more information on the types of lights and how they interact with different types of objects!

I’m sorry ,I’m a newer,maybe I inadvertently click the button .
If I rebuild the lighting ,it seems work ,but cast low and bad shadows ,the issue happens in another scence, I guess some preview or rendering option has turn on or off in my preference,here is tow pics that I screenshot yesterday,I hope you can found sth through them.

where is the lightmap resolution ,I can’t find it .

I just found the option is on the object whichi is casted,thank you

I set the resolution to 512,but it still work nothing, the shadow still bad and a little crooked.

Is the ground plane BSP? If so, try decreasing the light map resolution, since BSP works differently

I should decrease the resolution to 0?or other number?