Why materials with blend mode: translucent are so bright?!


I’m working with Epic’s material: M_Glass. I added a texture to this material and I noticed that in “detail lighting” (in Lit also) mode this material is super bright :\ Why? It looks really bad and I’d like to change it. Original material, without any texture is darker but also too bright.
When I change blend mode to opaque it works as it should IMO, but I want to keep original translucent mode.

What is going on? Please check out the screenshots (translucent vs opaque):


IF you need more information, please ask.

Behind both windows is only a wall from a different object. Windows- glass is a simple surface without back faces.

Both surfaces have the same, very simple shader and the thing that change the look is a blend mode:

Why are you using a translucent material for the windows if you aren’t going to give them an opacity value?

Like in original M_Glass material I’d like to use “refraction” slot and it’s available only in Translucent mode.

What is behind the window? If the one on the left is translucent, you should be getting some of the brightness from the other side of the window to affect the glass (if there is anything behind them). To me, the one on the left doesn’t look like glass but more like a grey opaque object? Do you have a screenshot of the material on the left hand window?

As Jacky said, if you want the windows to look like actual glass, you will want to add an opacity to the texture.
However, it looks like you are trying to have one texture to cover both the opaque (wood and such) and translucent (glass window) parts of your object which is going to cause more issues. Really, you need to separate opaque and translucent materials or try to mask each of them out.

Refraction and opacity arent the same thing though, and refraction is useless without opacity. As Dune said you need a mask to separate the windows first, then use that mask for opacity. Refraction comes final and it may not even be needed for this house really.

Man, I know. I don’t wanna use opacity :wink:

This is the window I’ve made. Some high end ■■■■ with parallax effect hehe. The only problem is that is too bright and looks really bad in shadows, that’s it.

Plus: "Like in original M_Glass material I’d like to use “refraction” slot and it’s available only in Translucent mode. "

Moderators cut my answer? eh… I’ll try once again:

I don’t need opacity. I already answered to this question: “Like in original M_Glass material I’d like to use “refraction” slot and it’s available only in Translucent mode.”

My window looks fine, the only problem I have is a fact that is too bright in shadows, that’s it.

I am a moderator and nobody cut your answer, it was the word filter that caught a word in your post and put it on hold for moderation.

To narrow it down, your material is set to TLM_Surface in translucency lighting mode, right?

Edit: Btw, you could do that parallax trick with BumpOffset instead of refraction.

Yes, Plus I’ve checked all 3 options and all of them just glow. Epic’s example material M_Glass also glows, less but still.

I’m unable to understand it. I don’t know if is’ some issue or just it works in that way but good looking curtains just glow like crazy in shadows. I can’t reduce this effect by reducing brightness of the diffuse map. In photoshop their brightness= 48%.

If someone wants to make some test please use M_Glass material from Epic’s Materials folder.