Download

Why is UNLIT texture appearing darker?

My material is set to Unlit/Opaque and the texture plugged into Emissive.

But in the game view or even the material editor if you change the viewport to Lit then the unlit textures get darker.

This is crushing my darkish sky materials down to black.
Running on 4.21 but see same effect on older versions.

Thanks for any help.

I don’t remember if this is normally the case, but your Unlit screenshot is missing tonemapping, which means it also has exposure disabled. Have you tested this in a real scene and not the HDRI previewer? Unless your scene is lit the exact same way, you’re going to see different results.

For starters, you can try rotating the view in the previewer so that you’re not looking at the sun in the HDRI and let auto-exposure adjust, or just lock auto-exposure to a value. But again, if your scene isn’t using a similar value it’s not going to look correct.

If you plan on keeping it unlit and use auto-exposure in your scene, and want to maintain constant luminance of the emissive material, you can divide the final emissive node by EyeAdaptation.

The Lit Mode has Post Processing and Tonemapping Applied, thats why even unlit materials look different between lit and unlit