Why is ue5 blank project is so slow and glitchy?

I created a blank project in ue5 and getting ~ 60 fps. In the blank project there is a landscape and some lighting. I heard about next level performance with lumen and nanite, so I don’t understand, should I have ~ 60 fps with gtx 1070 ryzen 5 2600x or I should turn on something? And I see strange artifacts and constantly “preparing” in that project.

In ue4 with blank project I have 120 fps, but in that case I don’t have landscape, maybe it’s affecting so much and I just should delete it?

Update: created a blank project like in ue4, still don’t have 120 fps, only ~ 90

P.S. for admin - can’t post my question with 5.0 version tag, so posted with 4.27, how can I fix it?

This is pretty standard for UE5. You can turn off lumen and nanite, but then you’re basically running UE4.

UE5 is still in early access. It will probably have a lot of bugs right now. If you can figure out the cause, you should probably report it.

But what about optimization? I thougth that ue5 will be much more faster than ue4.

I was tempted with news about better stability in preview 1…

The engine is doing more, that’s why it’s slower.

I don’t think anybody said 5 was going to be faster than 4.

1 Like

UE5 out of the box has many more features enabled than UE4 (Lumen GI, Lumen Reflections, Virtual Shadow Maps, Temporal Super Resolution). There’s no reason to expect UE5 out of the box to be faster than UE4.

1 Like

Also look at the output of the ‘profilegpu’ console command to understand where GPU costs are coming from, and then you can disable the ones that you don’t want to pay for.

Thank you, I’ll try it.

“FPS” is a terrible measurement on its own.

Are you sure you’re not getting vsync?
If you’re actually limited on the content, what is the limitation? CPU? Texture sampling? Fill rate? GPU upload? Something else?

“60 Fps” sounds very suspiciously like you’re just getting vsync frame rate.

Is vsync active by default?