Why is Ue4 Modifying my collision mesh?

Okej, so the left one is my collision mesh in maya, on to the right is the imported one in Ue4,
than why is it modifying my mesh? I have tried to do it a box but it is just doing the same?
what is going on?

So the answer is to delete the two edges and leave it as a plane?

Because your mash is concave and not convex.

Static mash pipeline

Or you can add 3 planes to your mash and name them according to the Caveats and Considerations part in the link above.
This will add 3 convex collision meshes to your model.

So you mean like this? they are called UCX_xxxxx_01 - 03
But now Ue4 can find them but not apply them?
Am I stupid or is it complicated?

Check this file

Oh, all make sense now! thx alot! :smiley:

You are more than welcome!

Can you please elaborate?

Out of the top of my head because you set on release and AFAIK it is hard coded to 300 it always returns to 300.

just one more question xD do you know what to do when I can’t set max walk speed anymore?

I have set a keyboard event: Left shift, then on pressed I set max walk speed to 600 and on released I set max walk speed to 300, but It won’t change from what I set it in the CharactarMovement (inherited) settings? wich is 300,