Download

Why is there visible jitter and jerkiness in game?

What is the likely culprit causing slight jitter and jerkiness in my game when I my character rotates?

I’ve slowed the max walk speed to 50 and the base turn rate to 10 as I need an archvis type walkthrough although showing events that are triggered via gameplay so matinee/sequencer not an option?

I’m running a gtx1080 to boot.

Would appreciate some input to help get my game smooth.

Can you share a screenshot or video recording of it so we can see what you mean?

Sure, here’s a video:
https://1drv.ms/v/s!Av7kWIyrlSmzpi3vM7GJ1IIJQOlf

Engine Scalability Settings:
8f661a5a8df113cd97759c6396e4da6228a4b1e1.jpeg

Some console commands I’ve tried to iron it out but no luck:
Settings.jpg

I’ve tried vsync=1 and setting max frame rate to 60, it just makes it worse.

Please help as its driving me mad!

i really appreciate your reply Amsanity!

Sorry I know little or nothing about Characters:
But are you far away from the origin (0,0,0)…
Experiencing noise related to Gimbal lock etc…

How do you mean origin?

See this thread:

Specifically here:

Taking location reference from a nearby trigger:

X:1920.0 cm Y:-291.0 cm Z:97.0 cm

Another strange thing thats happening is everytime I rebuild the lighting for the 3 lights in that room switch off, but when I select and then deselect “Affects world” is OK, but if affects a character in an adjacent room that you can no longer see half of them as they’re covered in shadow.

So I’m locked in this vicious circle that i need to rebuild lighting to sort the character shadowing, but then this kills the lighting in the room and the only way to correct it is to select/deselect “Affects world” and again messes the character lighting up!

AAAAAAAAAAGGGGGHHHHH!!!

Please help!!!

Hi Delta1,

It looks like the Motion Blur is missing. You can enable it in the Project Settings, Rendering.
By adding a Post-Processing volume in the scene, you can adjust the Motion Blur settings (under Rendering Features).

Also, sometimes it can help to change the Anti-Aliasing method (can also be found in the Project Settings under Rendering). :slight_smile:

I’m not sure if its the recording, but I see some static grain too.

Hi amsanity,

What settings would work with motion blur, ive already got a ppv in there.

I’ve tried fxaa as antialiasing but just removed it in the end as it makes it worse.

Edit:

I’ve tried multiple motion blur settings it doesn’t really change anything the jitter is still there.

Using the console command “Stat Unit” shows the “draw” value (all other 3 values are at a rock steady 8.33) dropping to around 2.3 at points when the camera is panning round, any ideas on how to improve this so it doesn’t radically jerk as it is doing atm?

Hi Delta,

Did you find any solution for this?

No unfortunately not

I don’t see why you can’t still use the sequencer. Something like this could carry the player through a walkthrough.
And you can still trigger events while the sequencer is running, you just have to build custom events with the “call in editor” checked.
Then you just have to sweat what’s going on with the camera.