Why is the Vertex Paint Tool so buggy?

Been using the tool quite a lot recently and there are quite a few issues with the way it works right now.

The first issue is that the brush disappears as soon as you start applying vertex paint, once you hit the mouse button the brush disappears and you can’t see where you’re applying the paint until you see the effects of it. Probably a simple fix for this I would have thought?

The second issue might simply be caused by the first, but I can’t tell, but the tool doesn’t seem to apply paint uniformly across the surface, some vertices will get a much more intense douse of the tool than others. UE3 seemed to paint much cleaner and more intuitively than UE4 so far.

Hi TheJamsh,

Can you get me a little bit more information on the problem you’re having?

Are you on UE4 4.1 or 4.0.2?
What type of mesh are painting on? Landscape, BSP, or imported mesh?
How many vertices does your mesh have?

Also, are there any circumstances that make this better or worse? Have you tried doing this in a new level?



I’ve been playing around with the tool in our latest internal build and on 4.1 but have not been able to replicate what you’ve indicated above. I’m sure there are different factors that would go into this replicating. In my test I was only using two textures using a 2(alpha lerp) on the Owen mesh from the content examples. While it was a bit sluggish during a few moments I couldnt get the brush to disappear.

If you could include a sample image of how you’re material is set up and some specific instances you’re using the paint tool in. Is this something that can be replicated every time with this material or all materials?

Any and all details would be helpful and if it’s something that can be replicated by your steps I can document and submit it to be looked at.

Hi TheJamsh,

It’s been a few days and we’ve not heard from you, I’m going to mark this as resolved for tracking purposes.



I am experiencing this same issue. To add to the list, sometimes when i turn on RGB, so i can view the colors. The mesh dissapears, others, it only shows me that mesh’s vertex colors. And other times it simply does not work.

So I ran into this on a recent project. Make sure that your face normals are pointing in the direction you think they are which in this case, needs to be toward the brush. You could try flying around to the other side of the object to see if the brush shows up. If so, there’s your problem.

I’ve also noticed that meshes seem to disappear when vertex painting if the mesh is set to translucent rendering mode. Opaque or masked seem to be ok, and don’t disappear assuming your normals are facing the correct direction.

It definitely still needs looking at.

I’m having real problems trying to get this to work. I can never visualise the actual brush size as it doesn’t show up in the viewport. I have to put the size up to about 1400/1500 for it just to paint anything (it’s very specific) anything other than that and clicking to paint simply moves the viewport around. I have to zoom into the mesh to an exact point until the verts show up, then it lets me paint, but with a brush so large that the entire model is flood filled as soon as I paint. Any smaller brush and I can’t paint at all. I am painting in RGB display and with a simple subdivided cube

Material doesn’t affect the outcome.

v 4.4.0

See below. The answer/fix is talked about. Check your normals. They are probably backward, and you aren’t aware because back faces are being drawn.

No it’s not that, I checked the normals already. I’m in a scene with a bunch of various objects and it works on none of them. I can see the brush now but still cannot get it to apply any colour to the meshes