Why is the Unreal Editor using so much network bandwidth while running?


It seems that UE4 is using my bandwidth quite heavily when I have the editor opened. Website navigation becomes very slow and I can’t hear or speak to my colleagues over VOIP. Once I close the Unreal Editor, it works again. (I’m not in simulate or play mode).

I tried to find some kind of network options but didn’t find anything revelant.

Are there some kind of permanent connection established when working with Unreal Editor ?

I’ve had a few friends with similar experiences. For them the problem was actually their router can’t handle the communication protocols somehow and continually crashes and reboots while unreal is open. While I’ve never found any network configuration settings in UE4 there is an “Offline” mode. Maybe that will do the trick for you.

1: Open the Launcher (Don’t sign in yet)
2: In the lower right corner there is a link to “go offline”
3: You should be able to start the engine from there.

Hopefully that helps?

Unfortunately, it does not solve my problem.

When I am in the launcher (offline mod or online mod) I don’t have this problem. But once I open a project it start to break my connection even in offline mod.

Hi Ambrosios,

Thanks for the feedback. We are currently investigating this issue.

Thanks, TJ


Is there any chance you can get us a Wireshark capture of your network traffic? A few seconds of data should suffice while your network is slammed.

Please also post the output of ipconfig /all as well as route print in a Windows command prompt, thanks!

Hi there, to test if the editor is causing this problem, you can disable all internet traffic from the editor by doing the following:

Note: Please only do this when the editor is closed or the settings wont take effect.

  1. In a file explorer navigate to where you created your project.

  2. In your project folder navigate to Saved\Config\Windows. Note: If you are using a Mac replace “Windows” with “Mac” in the folder path.

  3. Open the file named Engine.ini in this folder

  4. Add the following lines at the end of the file:


  5. Save the file and start the editor.

Let us know if that works for you

It didn’t work. Network is still broken.

Here is the Wireshark capture file. It’s the first time I’m using this so I don’t know if I did the right thing. Just launched a capture on my network adapter for 10 sec and save in .pcapng.

The result of command prompt is also in the archive.

Thank you for taking the time to try to solve my problem !

Hmm. My network is fine with UE, but then again, I noticed in recent weeks that I had to restart the router more and more often because the local network connection to it was lost. I figured it must be the power unit giving out (after reading in Google that is a commonly happening in routers), so I ordered a new one which will arrive in coming weeks.

Could it have been UE causing this?

SagemCom Fast3965b - ISP is Bouygues Telecom

My network line is quite bad as I loose my connection when I flood it. My issue with UE seems to be the same as when I’m downloading at max speed from a network browser (that’s why I use download speed limiter software).

Woot ! I disabled UDP Messaging and it works fine now ! What is this plugin for ?

Thank you for this information and for your help !

Best support ever :smiley:

Thanks for the log files, Ambrosios. They look OK overall, except for a small anomaly (each multicast packet is sent twice), which may indicate some interaction with your router.

Could you please tell me the make and model of your router?

Also, for troubleshooting, please go into your project’s Project Settings, scroll all the way down to Plugins, then select UDP Messaging, then disable the checkbox for Enable Transport and see if the problem immediately disappears.

Thanks for the info, we will investigate further!

The plug-in is used for a number of services in the Editor, such as discovering external devices, monitoring game sessions, profiling, automation testing etc.

It is using multicast to discover services on the network. There may be some network routers that do not play nice with this, and yours may be one of them. We are planning to implement a broadcast fallback for such cases, but haven’t time to implement it yet. I guess it just got bumped up in priority :slight_smile:

Ambrosios, could you please do me one more favor?

I would like to see the multicast handshake between your computer and your router. For that I would like you to make another Wireshark capture as follows:

  1. Start the Editor with the plug-in disabled
  2. Start a Wireshark capture
  3. Check the Enable Transport check box in the Editor
  4. Wait 5 seconds
  5. Uncheck the Enable Transport check box in the Editor
  6. Stop the Wireshark capture

Please attach the captured file, thanks!

Handshake result

I’m wondering if I did the right thing because I don’t have the check box that you talk about. I don’t have anything plugin related in project settings.

I used Plugins from Windows menu, scrolled down to UDP Messaging (which was unchecked), started wireshark, enable UDP Messaging plugin (which requires a restart of UE Editor), wait for 5 seconds, Uncheck UDP Messaging plugin (again restart) and stopped wireshark.

I’m afraid that this capture wasn’t quite enough. Can you start the capture before you launch the Editor and finish it after you shut down the Editor?

2nd handshake result

I think that worked this time. I saw red and black lines when I launched the Editor. Red is a bad guy …

Thanks, that worked! The color coding is actually just for showing various protocols. Red doesn’t mean bad. I am interested in the pale yellow lines (IGMPv2 packets). I’ll take a look at this in more detail later this morning and will get back to you, thanks!

Any updates on this?
I’m pretty sure I have the same issue