Why is SwarmAgent crashing after failing to connect to Swarm?

I am currently unable to build lighting in any of my projects or maps. It stops at 0:00:00 Starting up Swarm Connection… (98%) with the error message “Failed to connect to Swarm”.
I have tried disabling the Windows firewall, deactivate the antivirus (windows defender) and reinstalling unreal.
I am currently running version 4.0.1-2027741. Here is the log file of swarm agent.
Any help would be greatly appreciated.

Swarm Log:

Starting up SwarmAgent ...
 ... registering SwarmAgent with remoting service
 ... registering SwarmAgent network channels
 ... initializing SwarmAgent
 ...... checking certificate
 ......... certificate check has failed
 ...... initializing cache
 ......... using cache folder 'C:\Program Files\Unreal Engine\4.0\Engine\Binaries\DotNET/SwarmCache'
 ......... recreating SwarmAgent cache staging area
 ...... initializing connection to SwarmCoordinator
 ......... using SwarmCoordinator on RENDER-01
[PingCoordinator] Determined that we couldn't ping the coordinator
[PingCoordinator] Coordinator ping failed
 ......... SwarmCoordinator failed to be initialized
 ...... initializing local performance monitoring subsystem
 ...... local performance monitoring subsystem initialization failed

Having a similar problem. I’ve uninstalled my anti virus and shut down my firewall. Not even sure where to start to diagnose the problems. Swarm is booting up,but it ‘fails to connect’ and then swarm shuts down (or crashes).

My Windows Log:
<?xml version="1.0" encoding="UTF-16"?>
<WERReportMetadata>
	<OSVersionInformation>
		<WindowsNTVersion>6.1</WindowsNTVersion>
		<Build>7601 Service Pack 1</Build>
		<Product>(0x3): Windows 7 Home Premium</Product>
		<Edition>HomePremium</Edition>
		<BuildString>7601.18247.amd64fre.win7sp1_gdr.130828-1532</BuildString>
		<Revision>1130</Revision>
		<Flavor>Multiprocessor Free</Flavor>
		<Architecture>X64</Architecture>
		<LCID>1033</LCID>
	</OSVersionInformation>
	<ParentProcessInformation>
		<ParentProcessId>2088</ParentProcessId>
		<ParentProcessPath>C:\Windows\explorer.exe</ParentProcessPath>
		<ParentProcessCmdLine>C:\Windows\Explorer.EXE</ParentProcessCmdLine>
	</ParentProcessInformation>
	<ProblemSignatures>
		<EventType>CLR20r3</EventType>
		<Parameter0>swarmagent.exe</Parameter0>
		<Parameter1>1.7.2891.0</Parameter1>
		<Parameter2>53342c2f</Parameter2>
		<Parameter3>mscorlib</Parameter3>
		<Parameter4>4.0.30319.18444</Parameter4>
		<Parameter5>52717d7e</Parameter5>
		<Parameter6>3559</Parameter6>
		<Parameter7>2b</Parameter7>
		<Parameter8>System.Text.EncoderFallback</Parameter8>
	</ProblemSignatures>
	<DynamicSignatures>
		<Parameter1>6.1.7601.2.1.0.768.3</Parameter1>
		<Parameter2>1033</Parameter2>
		<Parameter22>f4c1</Parameter22>
		<Parameter23>f4c18d792700773fa4ea1141341d1f90</Parameter23>
		<Parameter24>f101</Parameter24>
		<Parameter25>f101bccf5f3c96c6fccb9276404384a5</Parameter25>
	</DynamicSignatures>
	<SystemInformation>
		<MID>424DD63C-2C5D-4D6B-93AF-83BC650CF57B</MID>
		<MarkerFile>1028_Dell_STU_8100</MarkerFile>
		<SystemManufacturer>Dell Inc.</SystemManufacturer>
		<SystemProductName>Studio XPS 8100</SystemProductName>
		<BIOSVersion>A05</BIOSVersion>
	</SystemInformation>
</WERReportMetadata>

Just found the logs: Same problem - certificate check has failed?

Starting up SwarmAgent …
… registering SwarmAgent with remoting service
… registering SwarmAgent network channels
… initializing SwarmAgent
… checking certificate
… certificate check has failed
… initializing cache
… using cache folder ‘C:\Program Files\Unreal Engine\4.0\Engine\Binaries\DotNET/SwarmCache’
… recreating SwarmAgent cache staging area
… initializing connection to SwarmCoordinator
… using SwarmCoordinator on RENDER-01
[PingCoordinator] Determined that we couldn’t ping the coordinator
[PingCoordinator] Coordinator ping failed
… SwarmCoordinator failed to be initialized
… initializing local performance monitoring subsystem
… local performance monitoring subsystem initialization failed

On another note, I have an old version of UDK and swarm runs just fine there.

The certificate check failure is ok. You can ignore it.

Could please try to go into the Settings and move the Cache directory into another location that is not under C:/ProgramFiles/, i.e. C:/Temp/SwarmCache/ or something like that?

Also try temporarily enabling verbose logging in the Swarm settings. Perhaps the log will provide some more details then, thanks!

Perhaps a silly question but how does one access the swarm settings? Remember, I can’t currently open swam - as it immediately crashes. This happens even if I execute it directly without going through the unreal build process.

I have a similar problem.
If I start the engine without admin rights I just see “connect to Swarm” the whole time when I wanna build the lighting.
But in the Task Manager “not responding”. I can wait a hour and nothing will do anything.

And if I start the engine with admin rights the lighting will build, but the whole 3d models (just brushes converted to static meshs) are black after building the light.

I’ve attached the logs.

I’m using the unreal engine 4 that I compiled in Visual Studio.

link textlink text

I fixed it, but you guys aren’t going to like the answer. I did a fresh re-install of windows and everything works just fine. Just an uneducated guess, but I think its something related to the.net stuff maybe?

Good luck!

Shir0s,

We have not heard from you in quite some time. I am going to mark this as accepted for tracking purposes. If you are still experiencing issues, please let us know. Thank you!

Had the same problem, solved by deleting the swarm cache. You can find the cache data here:
C:\Users\YourUsername\AppData\Local\UnrealEngine\4.1\Saved\Swarm\SwarmCache.Clear the cache and restart the Editor. This worked for me, allthough it doesn’t prevent swarm to crash later again.

This worked for me too… I had a different error: Lightmass cannot be run due to an incompatibility with 64-bit windows. I just deleted the whole SwarmCache folder, and it worked! Thanks lugit!

I use to have the same problem. the only thing I was able to do was to close unreal with taskmanager
after some testing and deleting cache folder , the problem was still there, until somehow it shows me a new window.

and I figure out that I compiled ue4 to my “G” drive and since a little while ago that I remove one of my HDD, and install this new windows , that drive has changed to “E” and “G” is now DVD drive and it cant write anything into it.

I think in most cases this is what cause the problem, you either don’t have permission to write into that drive or antivirus has blocked it, or you changed the installation directory.

This fixed it for me:

  • Delete the SwarmCache

C:\Users\YourUsername\AppData\Local\UnrealEngine\4.1\Saved\Swarm\SwarmCache

  • Uninstall all .NET related things
  • Reinstall the newest .NET Framework
  • (maybe) Run everything with Admin rights (can’t tell if this changes anything, but i did it.)

Make sure that the UnrealLightmass.exe file exists in the directory it’s expected to be in.

I had to build it from the UE4 solution. Not sure why it didn’t build when I built UE4 but this fixed my problem.

Hope this helps someone else.

This was the issue for me in 4.11 github needed to recompile Lightmass.

Hey so maybe bump my answer up? I could use the rep.

Yup, I had the same issue with 4.11 which I got via Github. I spotted the error in SwarmAgent’s log window telling it couldn’t cache the UnrealLightmass.exe which in turn didn’t exist in the Engine\Binaries\Win64 -folder.

Thanks Jin_VE :slight_smile:

@Dissipation I’m very upset. I’ve even format and reinstall the OS (w8.1) with everything new (the all .net framwork versions & all c++ VS distributed versions) no antivirus, no firewall. Just UE 4.13 version installed on the PC and still having errors. Check the last swarm log and my settings. Note: I’m just building the lights in a standalone PC.

The log

The swarm settings.
[link text][2]

Unreal Engine 4,5 | Failed to connect to Swarm error fix - YouTube hey I uploaded a video regarding its solution do check it out if it solves your issue, thank you so much