Why is playing network game "In New Window" not opening new windows for clients?

Hi all!

I am trying to debug a network game. I have 1 listen server and 2 or more clients running fine.

My problem is that I want to have the listen server and each client play in their own window. Currently, I play with the settings shown in the image.

But when I select “Play”->“New Editor Window” this is what happens:

Listen Server => Window opens in top left quarter of screen in split screen style.

Client1 => Window opens in center of screen as a new editor window (this is what I want for all of them)

Client2+ => Window opens in top left quarter of screen in split scree style.

So now the client and listen server are overlapping in these small split-screen windows in the top left of the screen while only one client is in a new window. When I say “split-screen style” I mean that they have no menu bar or anything with which I could use to move them. They are stuck there overlapping each other.

Please tell me what I’m doing wrong here.


Sorry to bump. I have tried all possible configurations and I can’t seem to get this to work. Any help would be greatly appreciated.

I’m a bit surprised I have to bump this again. Any input at all?

On the windows where you don’t see a border, can you try resetting the resolution? E.g, type ‘SetRes 640x480’ in those windows. That should resposition them in a way that can be moved. Drag the windows where you want them, then kill your PIE session (Stop in the main UE4 editor, or press escape in the editor PIE window). When you relaunch, the windows should remember where they were. (To be clear, this is a bug that we are trying to fix).

I would also suggest running with ‘Use Single Process’ checked if you can. Is there a reason you aren’t using this? This mode launches much faster and is generally more powerful since you can debug every game window in the blueprint debugger. Though there are cases where separate processes are still useful.

Sorry for the late response, please let me know if this helps.

Ahh, a few weeks ago I added some extra information to print messages to at least tell you if they were client or server instigated (a better fix would be to only print messages on the appropriate screen, though this doesn’t quite work for dedicated server mode and requires more surgery than we wanted to do at the time).

If you are compiling C++, you can manually take that change (If not, it should find its way into the next version):

Hi , thanks for the response. I will try this when I get home from work. I am not using “Use Single Process” checked because when I was debugging by printing values to screen, it would print to all Role specific debug messages to all screens. So Role == ROLE_Authority was printing on clients, etc. When I run them in separate processes this problem went away. I’ll try it again as well just to confirm.

Ah, nice. I’ll try this asap and let you know. Same with the suggested answer… I will get back to you this afternoon after I get home and give it a try.

Well, I assumed what you meant by “type ‘SetRes 640x480’ in those windows” you meant in the console of the window. I did this and nothing happened. The console autocompletes commands and SetRes was not appearing either. Again, I tried it anyway with no luck.

SetRes won’t autocomplete but it should reset the resolution. Were you already at 640x480? Maybe try a different res, 1280x720 for example:

You will see “Command not recognized” if the console command is really not registering.

SetRes 1280x720 worked. Thank you sir! I guess it was already at 640x480 so it didn’t reset.

They open up this way every time now. Thanks again , I really appreciate the help.

Great, glad to hear it. Sorry for the inconvenience, its a pretty annoying bug :slight_smile: