Download

Why is my lighting like this!!!

Guys,

I’ve got a very basic maze but for some reason, one side is incredibly dark and the other nice and bright as I intended it:
Shadow.jpg

I’ve tried turning auto exposure off, overriding the light map resolution, using 2 sided lighting for each cube that makes up each maze wall but to no avail.

How do I fix this?

Looks like u it set to Preview mode. Change it to production. If its on production… you probably dont have a skylight. Just add one. It gives you Global GI.

Is this baked? If you’re using a custom mesh make sure that the lightmap uvs aren’t overlapping.

Its a custom static mesh, but from the default cube mesh that comes with the editor starter content nothing imported from a 3d package.

As such how do I check for overlapping uvs?

Hi Syrom,

Lighting’s already set to production mode and it also already has a skylight, any ideas?

Try importing from a 3d application. Honestly, never worked eith the inside package geometry so i would know how it would look. But just give it a shot.

Or add a roof to see if that issue dissapears.

It shouldn’t be an import problem as I’m using the standard starter content cube mesh and I can’t put a roof on it as I’m trying to get it to look like an outdoor maze with a sky?

Upon completion of lightbuilding the editor will inform you whether or not lightmap uvs are overlapping. You can also check in the mesh editor. Open your mesh, click the Display UV button and change the UV channel to the highest one (typically your lightmap). Check it to see if there are overlapping islands. If it’s a cube, it should have 6 individual islands shown within the confines of the UV space. Also make sure that the mesh’s settings for lightmap UV reflect the actual channel number.

after rebuilding the lighting the editor gives it a clean bill of health, so no overlapping uvs, any ideas?

That is strange. Especially if you have a skylight in there. Not sure what else it could be.

Id start fresh again.

Its not even an option, I’ve just got too much work invested in this, there’s gotta be a way to resolve this!