Why is my Input Key press not working in Blueprint?

Hi,

I have a new Macbook pro, latest version of OSX. I cannot get the input key press to work in Blueprint. I tried the simplest version of them all (screenshot attached) and put a breakpoint - but I can’t get it to trigger. I did try using the inbuilt keyboard instead of the USB keyboard, restarted everything many times, but to no avail.

I did put a breakpoint to check - but it doesn’t trigger. I’m left to think that either I’m missing something real obvious.

2411-screen+shot+2014-03-26+at+15.39.34.png

If anyone had this before and managed to fix it, it would be great to hear how :slight_smile:

Thanks,

Christian

Hi cmiccio. Have you tried binding your input key to an action mapping?

  1. Open Edit > Project Settings > Engine > Input > Bindings.
  2. Press the “+” key to create a new entry, then give it an action name (eg. “jump”, “attck”, etc.).
  3. Expand the binding with the triangle icon and select the keys you want to map.
  4. Go back to your Blueprint graph, right click, and start typing the name of your action.
  5. You should see an Input > ActionEvents > $ActionName entry.

Have you followed the blueprint series on youtube?, If not check it out and if im not mistaken they add in an event for key presses and they walk you through it.

Hey cmiccio,

Are you working out of a Blank project or are you using one of the Template projects? If you are using one of the Templates, the Character blueprint in use may have Block Input enabled by default (you can check by opening the Character blueprint, going to Defaults and looking for the Input section > Block Input).

If all else fails, you may just need to Enable Input for your blueprint, but adding a BeginPlay event and connecting an Enable Input node to that event (you’ll want to pass in your PlayerController using a Get PlayerController node).

Hi cmiccio,

You want to make sure that you enable-input for your blueprint (it would be a performance issue if every single blueprint actor is listening for input events). You can do this using the “Enable Input” node, pictured here:

enableinput.png

Here’s our tutorial video demonstrating how to set up input to work with your blueprint: - YouTube

Hope this helps! - MikeB

6 Likes

Hi everyone, thanks for your super-quick and really useful answers. Learnt something from everyone of them :slight_smile:

I also had to click “possess” to get into the game mode…

i tried doing all of the above and I can’t seem to get any input on a pawn. I can trigger inputs from the PlayerController Blueprint I’m using by default but by putting an input like mouse wheel for example, isn’t being called in the Character Blueprint I’m using.

I built my project via Top Down Blueprint Template but my Character was created from scratch. So my PlayerController is the default controller that comes with the Top Down Template

Am I missing something?

Hey mykdragn,

Are you using a Mac with 4.01? I am and I had exactly the same trouble as you with none of the above working for me. Nothing I did would allow me to send input to a pawn. Anyway, I downloaded 4.1 and this fixed the issue so I assumed it was a bug. Bear in mind I had to create a new project too but a soon as I had done these two things all the steps I’d been trying previously worked.

Thanks

Hello cmiccio!

I was experiencing the exact same problem also with the Top-down project. None of the above solutions will work since the input handler at the top of the stack is the MyController Blueprint, which has its Defaults->Input->Block Input property set to TRUE. Flip that bit to FALSE and then user input gets sent down the stack to MyPlayer blueprint or any other object that is registered to listen.

Hi cmiccio,

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will offer further assistance.

Thank you.

This fixed my problem in the top-down template project using 4.6.1. Thanks!

Seems not to work in game mode blueprint.

Bravo! Thanks a lot, @Goshand!

It took me some time to figure out what to do, in order to implement your solution. It would be awesome if you could add the details in your answers for others to easily follow.

Nice one, thanks. This works with 4.8.0

1 Like

Select the actor in the world and under details there will be an option like “propagate keypresss” about half way down, tick that :slight_smile:

Ok Yes, but for me and other the problem is not this, you have explained how create an input event like jump and attack but my issue, and the issue of the post owner is another, we can’t raise the event also after the creation of it. enable input don’t change the situation but the solution of Goshand it’s good

Hi, I know it’s a little late but this totally worked for me using 4.14.3 - in case anyone has the same problem.

Was having a similar problem and, in case someone else went through all of these solutions to no avail:

Check the InputAction isn’t in use by another blueprint, because the other blueprint may have the ‘consume input’ toggle enabled, which stops any other blueprints from listening.

it works, thx a lot

I can’t find the Defaults. Are they the “Checklist” Symbol in the top right?
Because then I can’t find block input neither