Download

Why Is My Grass Overlit and How To Fix It?

I’ve been struggling with getting realtime grass to look good.

I am using Megascans MeadowPack for the Grass.

I have no idea what i’m doing wrong, I know I can adjust the lighting intensity but that changes the whole scene.
Is lightbaking the only thing that will fix this?

Only when looking at the grass from the back with SSS it looks decent.

Here are some screenshots regarding my issue, as you can see in the sunlight the grass is almost bright white;

Open the textures for the grass in the texture editor. To do so:

Access the grass material in the material editor by double-clicking the material (in content browser or in material slot of details panel) or right-clicking material and selecting edit.
Double-click the image preview of its texture(s) in the sampler node.

or, alternatively, go to the Textures folder of the grass, double-click on a texture or right-click and select Edit.

Once it’s opened, scroll down to the Adjustments properties.
Try changing one or more of Brightness, Brightness Curve (increasing darkens, decreasing brightens), Saturation (could help to increase it a bit), and RGB Curve (like contrast).

1 Like

Oh wow thanks man, I didn’t even know UE4 had a texture editor!

Is this how you wish it to be

Yes that’s exactly how I want it to look like.

You really can’t expect the default mega scans material to look nice or function with any amount of decent performance while looking nice.

First, the assets usually use too large a texture.
second, I doubt the material uses all the nodes and settings you should have on grass.
temporalAA dither, per instance fade, sub surf profile, etc.

Start by making your own material without any textures. After you finetune how it works, the fade distance and the rest of the settings you want (like squishing the mesh down at a distance or growing it vertically at will) you can focus on texturing - which is an artistic thing more-so than a technical one.

I’m glad to share it with you This scene is baked and I turned on static cascade shadows and distance field environment occlusion To prevent the shadows from getting too dark I increased the ambient occlusion luminance It works a little bit better but there are still some problems that can’t be solved

Shame, I thought the Megascans packs on the marketplace would be ready to go on the fly… I only lowered the resolution, because 4K is ridiculous for grass…
I’m not going to make my own grass even though im a 3d artist, because i REALLY hate modelling foliage.
So i’ll try and create a shader from scratch, see what I can come up with.

Sure, i have no problems downloading your project if you are willing to share it.
What UE4 version did you use?

A scene test I did myself 4.25

Cool, anywhere I can download it for testing it myself?

yes Can I send emails

Sorry for responding so late, had to do take almost a month off from doing anything.

Can you upload the files on drive or mega perhaps so i can download them?