Why is my FBX import missing color and texture?

Can someone tell me why colors and textures are not coming in from FBX import. original is a SketchUp file.

Hey MetalD,

It sounds like a bad export. If we can see what your export settings, we might be able to help. We would also like to know which version of SketchUp you’re using.


I am using Sketchup 14. These are export settings I am using.


These are Unreal 4 import options I have selected.

Is it SketchUpMake? Or SketchUpPro?

any luck with this? I’m also facing same issue. materials I apply to an imported fbx (exported as a dae and converted) will not render correctly. Please let me know if you solved this issue. Thanks in advance

Hello MetalD -

In past I worked with another user helping them get Meshes successfully into Sketchup here, How do I get correct scaling for sketchup in UE4? - Rendering - Epic Developer Community Forums.

For your import, I would make sure that you color is not vertex color which does not export from Sketchup correctly via FBX, but your texture maps should import, but as I mention in post linked above. It would be in your best interest to import textures separately and construct your materials in UE4. In this way, you will get best possible results.

Thank You

Eric Ketchum