Why is my C++ Character not showing up in editor?

I coded a c++ character and I am trying to extend that with a blueprint. However, after I compile the code, the class does not appear int the dialog to create a new blueprint! Any ideas as to how to fix this? At the moment the code is just a basic constructor. here is the code…

.cpp file:

#include "Dragentria.h"
#include "HumanCharBase.h"

AHumanCharBase::AHumanCharBase(FObjectInitializer& Init) : Super(Init) {


.h file:

#pragma once

#include "GameFramework/Character.h"
#include "HumanCharBase.generated.h"

class DRAGENTRIA_API AHumanCharBase : public ACharacter

		AHumanCharBase(FObjectInitializer& Init);


Hi Zack

Make sure this code compile correctly. Because in my case I need declare constructor like this

AMyCharacter(const FObjectInitializer& Init);

Also, make sure you compile for editor (in editor press Compile button). In addition, Class Viewer has filters menu try to disable Placeable Only.

Hope it helps!

That is because your class does not have the property set to expose it to the blueprint. You need to add:
UCLASS(Blueprintable) for classes and UPROPERTY(EditAnywhere, BlueprintReadWrite) for properties.

Still no luck unfortunately.

Try to create class through editor.
File->Add Code to Project->Choose Character like parent class and setup class name->CreateClass
Compile it. After compilation, this new class should be in your class wizard. By default it is placeable and has capsule component

That is what I did already…

I got it! My solution was to recompile from VS 2013 with the UE4 editor closed. Then I opened up the editor again and there was my class!!!