Why does VR Interactions break in Collab Viewer Template?

Hi All,

I am having issues working with the Collab Viewer template when using VR.

While I am able to view and move around in VR, as soon as a press the controller button to open the interaction menu and press a button my controllers no longer receive inputs. I have tried starting a new template as well as packaging but this seems to be a recurring issue. Currently Using Oculus Quest 2 for testing.

Why is this the case?

Hi DBE, Welcome to the Forums,

I’m seeing the same thing in the 5.1 Collab viewer template, I tried the 5.0 template and it is working normally there.

Unsure as to ‘why’, but there were some fixes applied to widget interaction that could resolve this in a 5.1 hotfix or 5.2

1 Like

Same here. Anyone reported as bug or should I?

I searched issues.unrealengine.com for “collab viewer” and found this: Unreal Engine Issues and Bug Tracker (UE-172475)

In my case, I did not find it necessary to enable OpenXR plugin to repro.

Its still there in 5.3 and the hotfixes are not avaiable for the other versions.