Download

Why does PPV darken scene?

If I place a PPV around a mostly enclosed area of geometry (such as the 3rd person shooter template with a ceiling and a wall missing), or an unenclosed one, it darkens everything. Even if everything for lighting is disabled, it is darker when the Blend Weight is higher than 0…going from actual lighting I have in the scene (brighter) to darker (BW value of 1). Is one or more of the settings in it still active even when unchecked (e.g., tonemapper, or AO). I don’t think it is because when I change those values with camera in the PPV, it doesn’t change how dark it is. And it’s only darker when the camera is inside the PPV. Hence, when it’s unbound, it darkens the entire level wherever I view the scene.

I have a theory, that in 4.25, Epic accidentally left the ‘exposure compensation’ on, even when you’re not using auto exposure.

Can you give it a tweak and see if that’s it?

can you please share a pic? I’ve got exactly the opposite problem so I may be helpful

@ClockworkOcean Actually, I’m using 4.24.2, but I bet it happens in 4.25 too…I haven’t downloaded it yet. I tried that, though. I set the range values (min and max) to the same setting (1). Is that too dark? I’ll try increasing it.

@KhappaMJ I’ll get 2 screenshots to compare. When I didn’t have a PPV in the scene, I had the problem of overbrightening when looking at the floor or down at an angle at the floor and top surfaces of objects. I thought that is auto exposure when it does that, but I had no PPV there. Then I added the PPV, and it was dark, no real-time gradient transition either, simply the brighter lighting outside the volume and instantly dark when entering the PPV.

So, I figured it out. When Blend Weight of the PPV is at 1, and the Min/Max EV100 (using Extended Luminance Range that activates EV100 units) are each at 1, it’s darker than outside it. At 0 Min/Max EV100, it’s the same lighting as without the PPV, and also as viewing into the area from outside the PPV when it’s there. I also noticed that the Lightmass Importance Volume causes a brightening effect or smooth transition to brighter when I’m just inside it, but not inside the PPV (with the Min/Max EV100 settings at 1 or 0). However, when entering the PPV, it quickly transitions (but not instantaneously) to the lighting inside the PPV. Now I have two questions:

  1. Is Priority of the PPV able to override, mix, or remain secondary to the Lightmass Importance Volume? secondary meaning the Importance Volume overrides the PPV if it has a higher priority set by a value or another way.
  2. Does the Lightmass Importance Volume have an auto-exposure system in it? or is it merely displaying the concentration of photons in the area it covers?


Outside PPV, Blend Weight = 1, Priority = 0, Blend Radius = 0, not Unbound


Inside PPV, Blend Weight = 1, Priority = 0, Blend Radius = 0, not Unbound

Yours is getting brighter inside the PPV, then, @KhappaMJ?

My guess is it’s either Exposure Compensation is higher than 0, Min/Max are lower than 0, or if using the camera…it’s a different setting.

yes I got some bright inside the PPV (I’m not using baked lightmass).
I see you have min EV100 and max set to 1.0 Try with negative value of Min EV100. Then most of the work has to be done in the Skylight. If you disable “Affect the World” you may notice that this problem should disappear. So basically you can compensate this just reducing the Skilight intensity and adjusting Camera exposure in the post process.
Let me know if that work :slight_smile:

I’m using dynamic lighting too. Though I don’t recall if I have “Force No Precomputed Lighting” enabled. I already had fixed it by changing the EV100 values to 0, min and max. I don’t have the camera exposure settings enabled, so I didn’t adjust those. Reducing skylight intensity could work, but if I need the higher intensity of skylight for other areas, then adjusting the PPV is useful for changing only the lighting inside it. I’m really new to things still, so I’m learning how the PPV and different lighting methods work in combination.

“Force No Precomputed Lighting” enabled is perfects. Well but if you set EV100 to zero you lose the eye-light effects.
But it’s fine if you don’t need to touch Skylight

I’m simply testing the lighting settings I have in the level to see how things work. When encountering the darkening effect with the PPV, I didn’t know how it resulted in it, and wanted to see how to fix it. The skylight is movable, with the usual cubemap, and the lighting looks good overall. However, it’s just a simple scene, not much changed from the initial template. Do you know how to get distance field shadows to function with non-procedural grass?

Skylight movable is fine too.
No I dont know about distance field shadows and grass.
Can I ask you a question about shadow buddy? I’ll be opening a post about it. I think you’re using same setup as mine. Have encountered any issue with shadows close to the objects but a bit far from camera?

Yeah, the shadows can start appearing, or suddenly appear, detached from the caster and a bit inaccurate. They may also disappear somewhat, which would most likely be CSM (cascaded shadow maps) settings. They disappear in a transition, not instantly, as though they’re being erased or wiped away. There’s a few settings for CSM that need changing to solve that.

So basically it’s about cascade shadow maps? Well, can I just try to bypass this type of shadows?

When opening a post of it, attach screenshots of the directional light’s CSM settings, and distance field settings. Include a screenshot or two of the exact problem with the shadows. I’ll see if I can reproduce it in a project.

Ok I’ll do that :slight_smile: