Why does my texture look weird in editor?

Hello, i have an issue with texture import. I downloaded this Leaderboard Icon from google console documentation but i can’t get it to display correctly on ue4. Here is the Image (yes there is one, it’s white with transparent background) :


Here is the image imported to ue4 :


Texture settings are set to default settings so sRGB is checked, view is set to RGBA.

What do you think about it?

Something is wrong with your png image. It’s the same for me, but after I re-saved the image it started to import normally.

Try to use a different image editor to save the image, or re-save it with some different options for png. I’m not sure what exact option is wrong here.

Or just use a different format, png is known to work not good with Unreal. For instance, try Targa (tga) format.

I’ve downloaded the first image and when I opened it I can see it’s semi transparent. Stacked few layers of the same image on top of each other and it looks way better inside the engine. Attached it below. Hope that helps.


Thank you, re-exported the image using the tga format and it now work perfectly :slight_smile:

Thank you for you answer, problem solved below :slight_smile: