Why does my static mesh disappear in the scene capture 2d - shadow's there

hey guys,
i have a very strange problem. i’m trying to capture the scene but every time some static meshes dissappear, wether moveable or static, but the shadow of the object remains.
i’ve tried everything, the flags in the options of the scene capture are all checked…

my scene in general: im trying to fake a truman-show-like sky. I have built the outter part of the enviroment which should be projected on the sky-box +10000 in the y-axis direction and let the scene capture 2d fallow the location & rotation of the player (then add 10000 to it).

so everything works fine, but i want to have a car driving down the road. but there’s always just the shadow projected and i cant get my head around why. i’ve double checked that the mesh is there & not getting culled.
and why does the enviroment itself doesn’t disappear, its also a static mesh? doesnt make sense
see my pic for better understanding
don’t mind the crappy google streetview enviroment, thats just a placeholder
thanks =)

Hi Schauk,

I’m not sure exactly what’s going on, since I cannot reproduce this with default settings and simple meshes for my scene.

I’ve setup a simple 2D scene capture camera and I have both a movable and static Sphere Shape mesh that seems to work.

Can you verify if simple objects like that are working on your end as well? If so, it could be mesh specific, in which case select the mesh and in its Details Panel check to see if “Render in Main Pass” is unselected, or if Actor Hidden in Game is selected.

If that still doesn’t work, can you try in a new project and see if this is still happening?

Let me know.


thanks for your helpful advices, but i’ve already tried it all that you mentioned before.

but i finally made it work =) the answer was so simple… i had to change the max view distance override. i changed it to 3000 & now i see the car driving down the entire length of the street. but it seams odd to me that the shadow wasn’t effected. but hey, now it works so anything’s fine.

thanks anyways! :slight_smile: